aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-20 09:40:44 -0700
committerKhem Raj <raj.khem@gmail.com>2021-03-20 23:53:13 -0700
commit3495464942f539275b9cd57ad30c67055ed0afcc (patch)
treef195eef96ce8cf120f403f25f2f9ab7caf6dfb17 /meta-gnome/recipes-gnome
parente9577c60fe0a692607114fd37aee4406e655d654 (diff)
downloadmeta-openembedded-contrib-3495464942f539275b9cd57ad30c67055ed0afcc.tar.gz
gsound: Use () instead of {} for makefile variable in gsound_play_VALAFLAGS
Fixes build with latest perl/autoconf Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Andreas Müller <schnitzeltony@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome')
-rw-r--r--meta-gnome/recipes-gnome/gsound/gsound/0001-Set-vapidir.patch28
-rw-r--r--meta-gnome/recipes-gnome/gsound/gsound_1.0.2.bb2
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gsound/gsound/0001-Set-vapidir.patch b/meta-gnome/recipes-gnome/gsound/gsound/0001-Set-vapidir.patch
new file mode 100644
index 0000000000..ffccfd56f2
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gsound/gsound/0001-Set-vapidir.patch
@@ -0,0 +1,28 @@
+From 0a790273aca3ba07dfa6d2f61e3aaa7157c1a3bb Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 20 Mar 2021 09:22:18 -0700
+Subject: [PATCH] Set vapidir
+
+Use parentheses instead of braces, it makes automake and perl happy
+newer perl does not like ${} for VALAFLAGS
+
+Unescaped left brace in regex is deprecated here (and will be fatal in Perl 5.30), passed through in regex; marked by <-- HERE in m/^${ <-- HERE abs_top_builddir}/gsound$/ at TOPDIR/build/tmp/work/mips32r2-yoe-linux/gsound/1.0.2-r0/recipe-sysroot-native/usr/bin/automake line 5759.
+autoreconf: error: automake failed with exit status: 255
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ tools/Makefile.am | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+--- a/tools/Makefile.am
++++ b/tools/Makefile.am
+@@ -8,7 +8,7 @@ bin_PROGRAMS = gsound-play
+ gsound_play_SOURCES = gsound-play.vala
+
+ gsound_play_VALAFLAGS = \
+- --vapidir ${abs_top_builddir}/gsound \
++ --vapidir $(abs_top_builddir)/gsound \
+ --pkg gsound \
+ ${NULL}
+
diff --git a/meta-gnome/recipes-gnome/gsound/gsound_1.0.2.bb b/meta-gnome/recipes-gnome/gsound/gsound_1.0.2.bb
index e4478e14a3..65ee1e1c12 100644
--- a/meta-gnome/recipes-gnome/gsound/gsound_1.0.2.bb
+++ b/meta-gnome/recipes-gnome/gsound/gsound_1.0.2.bb
@@ -9,5 +9,7 @@ DEPENDS = " \
inherit gnomebase gettext gobject-introspection vala
+SRC_URI += "file://0001-Set-vapidir.patch"
+
SRC_URI[archive.md5sum] = "c26fd21c21b9ef6533a202a73fab21db"
SRC_URI[archive.sha256sum] = "bba8ff30eea815037e53bee727bbd5f0b6a2e74d452a7711b819a7c444e78e53"