aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/metacity/metacity_3.32.0.bb
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2019-08-02 15:59:34 -0400
committerKhem Raj <raj.khem@gmail.com>2019-08-02 18:04:41 -0700
commit7230755941d948026594e9d4149fc5fd03152055 (patch)
treee5697fc51f7175ffef7c9d30bf650ed0abd04a71 /meta-gnome/recipes-gnome/metacity/metacity_3.32.0.bb
parent04473965b42b795b53adc5e75192b49ce9cc902d (diff)
downloadmeta-openembedded-contrib-7230755941d948026594e9d4149fc5fd03152055.tar.gz
metacity; upgrade from 3.30.1 to 3.32.0
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/metacity/metacity_3.32.0.bb')
-rw-r--r--meta-gnome/recipes-gnome/metacity/metacity_3.32.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/metacity/metacity_3.32.0.bb b/meta-gnome/recipes-gnome/metacity/metacity_3.32.0.bb
new file mode 100644
index 0000000000..ef6ea7946a
--- /dev/null
+++ b/meta-gnome/recipes-gnome/metacity/metacity_3.32.0.bb
@@ -0,0 +1,41 @@
+SECTION = "x11/wm"
+SUMMARY = "Metacity is the boring window manager for the adult in you"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b4cce53560b8e619ffa7c830fb8761aa \
+ file://src/include/main.h;endline=24;md5=72148ede07a6dadd01de6a882d20a9ad"
+
+PE = "1"
+
+DEPENDS = "gsettings-desktop-schemas startup-notification \
+ gnome-doc-utils gdk-pixbuf-native \
+ gtk+3 glib-2.0 libcanberra libgtop intltool-native"
+
+inherit autotools gettext gnomebase distro_features_check
+# depends on startup-notification which depends on virtual/libx11
+REQUIRED_DISTRO_FEATURES = "x11"
+
+SRC_URI = "git://github.com/GNOME/metacity.git;branch=master \
+ file://0001-drop-zenity-detection.patch \
+"
+
+S = "${WORKDIR}/git"
+SRCREV = "bf1bfbadf47eff97703df17e95b15168e2034222"
+
+EXTRA_OECONF += "--disable-xinerama"
+
+PACKAGECONFIG ?= ""
+
+# enable as neccessary until new warnings are dealt with
+PACKAGECONFIG[werror] = "--enable-Werror,--disable-Werror,,"
+
+do_configure_prepend() {
+ cd ${S}
+ aclocal --install || exit 1
+ autoreconf --verbose --force --install -Wno-portability || exit 1
+ cd -
+
+}
+
+FILES_${PN} += "${datadir}/themes ${datadir}/gnome-control-center ${datadir}/gnome"
+RDEPENDS_${PN} += "gsettings-desktop-schemas"
+