aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/grilo/grilo_0.3.13.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2020-09-20 16:50:31 +0200
committerKhem Raj <raj.khem@gmail.com>2020-09-20 12:47:40 -0700
commit8e82b89110beea21bbab1fe1df3175574b46ecfd (patch)
tree3f852618b0aa3e77f63342e21814148bf9198459 /meta-gnome/recipes-gnome/grilo/grilo_0.3.13.bb
parent264f979814883475755dad6703743c78bed1b6a2 (diff)
downloadmeta-openembedded-contrib-8e82b89110beea21bbab1fe1df3175574b46ecfd.tar.gz
grilo: upgrade 0.3.12 -> 0.3.13
NEW in 0.3.13 ============= * !56 Increase glib requirement to 2.58 or greater * !58 API addition: grl_related_keys_set_for_id() * !59 Fix trying to load .so.p files as plugins * !61 Fix crash using get_plugins() from bindings * Several other fixes and cleanups * Updated translations * Chinese (Taiwan) * Japanese * Ukrainian Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/grilo/grilo_0.3.13.bb')
-rw-r--r--meta-gnome/recipes-gnome/grilo/grilo_0.3.13.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/grilo/grilo_0.3.13.bb b/meta-gnome/recipes-gnome/grilo/grilo_0.3.13.bb
new file mode 100644
index 0000000000..fe6858f45e
--- /dev/null
+++ b/meta-gnome/recipes-gnome/grilo/grilo_0.3.13.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Grilo is a framework forsearching media content from various sources"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+
+DEPENDS = " \
+ libxml2 \
+ glib-2.0 \
+"
+
+GNOMEBASEBUILDCLASS = "meson"
+
+inherit gnomebase gobject-introspection gtk-doc gettext vala
+
+SRC_URI[archive.sha256sum] = "d14837f22341943ed8a189d9f0827a17016b802d18d0ed080e1413de0fdc927b"
+
+GIR_MESON_OPTION = "enable-introspection"
+GTKDOC_MESON_OPTION = "enable-gtk-doc"
+
+# Note: removing 'net' from PACKAGECONFIG causes
+# | bindings/vala/meson.build:15:0: ERROR: Unknown variable "grlnet_gir".
+PACKAGECONFIG ??= "net"
+
+PACKAGECONFIG[net] = "-Denable-grl-net=true, -Denable-grl-net=false, libsoup-2.4"
+PACKAGECONFIG[test-ui] = "-Denable-test-ui=true, -Denable-test-ui=false, gtk+3 liboauth"
+
+# Once we have a recipe for 'totem-plparser' this can turn into a PACKAGECONFIG
+EXTRA_OEMESON = "-Denable-grl-pls=false"
+