aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gjs/gjs_1.70.0.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2021-10-11 17:18:38 -0700
committerTim Orling <ticotimo@gmail.com>2021-10-18 10:38:31 -0700
commit2831020b3eb6884bdf7613a146e035ef1b3e0097 (patch)
tree46b3a59aa2f5ea5beb004b4f71fcc2d0d819b324 /meta-gnome/recipes-gnome/gjs/gjs_1.70.0.bb
parent25fe7751e8e95a4604fbcd062616fb5fedeaf1c4 (diff)
downloadmeta-openembedded-contrib-2831020b3eb6884bdf7613a146e035ef1b3e0097.tar.gz
gjs: upgrade 1.58.8 -> 1.70.0
Drop config.ac patch as build system is now meson Drop backported patch Use SPDX license identifier for LGPL-2.0-or-later License-Update: Clarified dependency licenses; remains MIT & LGPLv2+ Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/gjs/gjs_1.70.0.bb')
-rw-r--r--meta-gnome/recipes-gnome/gjs/gjs_1.70.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gjs/gjs_1.70.0.bb b/meta-gnome/recipes-gnome/gjs/gjs_1.70.0.bb
new file mode 100644
index 0000000000..7ffd611455
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gjs/gjs_1.70.0.bb
@@ -0,0 +1,34 @@
+SUMMARY = "Javascript bindings for GNOME"
+LICENSE = "MIT & LGPL-2.0-or-later"
+LIC_FILES_CHKSUM = " \
+ file://COPYING;md5=8dcea832f6acf45d856abfeb2d51ec48 \
+ file://LICENSES/MIT.txt;md5=38aa75cf4c4c87f018227d5ec9638d75 \
+ file://LICENSES/LGPL-2.0-or-later.txt;md5=6d2d9952d88b50a51a5c73dc431d06c7 \
+"
+
+GNOMEBASEBUILDCLASS = "meson"
+
+DEPENDS = "mozjs gtk+3"
+
+inherit gnomebase gsettings gobject-introspection vala gettext features_check upstream-version-is-even pkgconfig
+
+SRC_URI[archive.sha256sum] = "4b0629341a318a02374e113ab97f9a9f3325423269fc1e0b043a5ffb01861c5f"
+
+# gobject-introspection is mandatory and cannot be configured
+REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
+UNKNOWN_CONFIGURE_WHITELIST:append = " --enable-introspection --disable-introspection"
+
+EXTRA_OECONF = " \
+ --without-dbus-tests \
+ --disable-installed-tests \
+"
+
+FILES:${PN} += "${datadir}/gjs-1.0/lsan"
+
+PACKAGES =+ "${PN}-valgrind"
+FILES:${PN}-valgrind = "${datadir}/gjs-1.0/valgrind"
+RDEPENDS:${PN}-valgrind += "valgrind"
+
+# Valgrind not yet available on rv32/rv64
+RDEPENDS:${PN}-valgrind:remove:riscv32 = "valgrind"
+RDEPENDS:${PN}-valgrind:remove:riscv64 = "valgrind"