aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gjs/gjs_1.58.8.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2020-09-20 16:50:36 +0200
committerKhem Raj <raj.khem@gmail.com>2020-09-20 12:47:40 -0700
commit80b76f79d102eab07ea08fcee90791e677f2825d (patch)
treeb77f828cb4e838337627d9156e315ce396c24b64 /meta-gnome/recipes-gnome/gjs/gjs_1.58.8.bb
parentab6a105b8a483de652ca6df51911ffe02f1c507d (diff)
downloadmeta-openembedded-contrib-80b76f79d102eab07ea08fcee90791e677f2825d.tar.gz
gjs: upgrade 1.58.7 -> 1.58.8
Version 1.58.8 -------------- - Various backports * 1.63.3: test suite is failing [Philip Chimento] * Various fixes for potential crash and memory issues [Philip Chimento] Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-gnome/gjs/gjs_1.58.8.bb')
-rw-r--r--meta-gnome/recipes-gnome/gjs/gjs_1.58.8.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gjs/gjs_1.58.8.bb b/meta-gnome/recipes-gnome/gjs/gjs_1.58.8.bb
new file mode 100644
index 0000000000..dbb04ef8e3
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gjs/gjs_1.58.8.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Javascript bindings for GNOME"
+LICENSE = "MIT & LGPLv2+"
+LIC_FILES_CHKSUM = " \
+ file://COPYING;md5=beb29cf17fabe736f0639b09ee6e76fa \
+ file://COPYING.LGPL;md5=3bf50002aefd002f49e7bb854063f7e7 \
+"
+
+GNOMEBASEBUILDCLASS = "autotools"
+
+DEPENDS = "mozjs gtk+3"
+
+inherit gnomebase gsettings gobject-introspection vala gettext features_check upstream-version-is-even
+
+SRC_URI[archive.sha256sum] = "7fb3eb746c17363d9ee47f4a5d0bb048f0075611763eb0da11d85e0e57aff381"
+SRC_URI += "file://0001-Disable-tests-on-host.patch"
+
+# gobject-introspection is mandatory and cannot be configured
+REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
+UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-introspection --disable-introspection"
+
+EXTRA_OECONF = " \
+ --without-dbus-tests \
+ --disable-installed-tests \
+"
+
+do_configure_prepend() {
+ # make configure find gobject-introspection test code. Although we set
+ # --disable-installed-tests gjs builds them
+ sed -i 's|:$GI_DATADIR|:${STAGING_DIR_NATIVE}$GI_DATADIR|g' ${S}/configure.ac
+}
+
+FILES_${PN} += "${datadir}/gjs-1.0/lsan"
+
+PACKAGES =+ "${PN}-valgrind"
+FILES_${PN}-valgrind = "${datadir}/gjs-1.0/valgrind"
+RSEPENDS_${PN}-valgrind += "valgrind"