aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-connectivity
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-08-06 22:17:43 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-24 13:51:36 +0200
commit555a0355c05965632d90846ea01e3e9edbdd91e0 (patch)
tree8875ac690b7fa221ca359fd7f82257233f95a193 /meta-gnome/recipes-connectivity
parenta2fcedbe20664d5be5e8c00ece3e2f95e8f2b1a3 (diff)
downloadmeta-openembedded-contrib-555a0355c05965632d90846ea01e3e9edbdd91e0.tar.gz
network-manager-applet: update to 1.0.4
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-connectivity')
-rw-r--r--meta-gnome/recipes-connectivity/network-manager-applet/files/0001-Add-support-for-AP-mode-setting-for-wifi-sharing.patch28
-rw-r--r--meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.0.4.bb (renamed from meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.0.2.bb)4
2 files changed, 18 insertions, 14 deletions
diff --git a/meta-gnome/recipes-connectivity/network-manager-applet/files/0001-Add-support-for-AP-mode-setting-for-wifi-sharing.patch b/meta-gnome/recipes-connectivity/network-manager-applet/files/0001-Add-support-for-AP-mode-setting-for-wifi-sharing.patch
index d0506b2e8e..db7878e897 100644
--- a/meta-gnome/recipes-connectivity/network-manager-applet/files/0001-Add-support-for-AP-mode-setting-for-wifi-sharing.patch
+++ b/meta-gnome/recipes-connectivity/network-manager-applet/files/0001-Add-support-for-AP-mode-setting-for-wifi-sharing.patch
@@ -8,11 +8,11 @@ Upstream-Status: Pending [1]
[1] https://bugzilla.gnome.org/show_bug.cgi?id=734589
---
src/connection-editor/ce-page-wifi.ui | 3 +++
- src/connection-editor/page-wifi.c | 46 ++++++++++++++++++++---------------
- 2 files changed, 30 insertions(+), 19 deletions(-)
+ src/connection-editor/page-wifi.c | 48 ++++++++++++++++++++---------------
+ 2 files changed, 31 insertions(+), 20 deletions(-)
diff --git a/src/connection-editor/ce-page-wifi.ui b/src/connection-editor/ce-page-wifi.ui
-index e2e544b..b8b27c1 100644
+index a7b8f20..0bd9130 100644
--- a/src/connection-editor/ce-page-wifi.ui
+++ b/src/connection-editor/ce-page-wifi.ui
@@ -50,6 +50,9 @@
@@ -26,11 +26,11 @@ index e2e544b..b8b27c1 100644
</object>
<object class="GtkTable" id="WifiPage">
diff --git a/src/connection-editor/page-wifi.c b/src/connection-editor/page-wifi.c
-index d0a5617..17db2fa 100644
+index 8a25c64..e4b4df1 100644
--- a/src/connection-editor/page-wifi.c
+++ b/src/connection-editor/page-wifi.c
-@@ -59,6 +59,12 @@ typedef struct {
- gboolean disposed;
+@@ -58,6 +58,12 @@ typedef struct {
+ int last_channel;
} CEPageWifiPrivate;
+enum {
@@ -42,7 +42,7 @@ index d0a5617..17db2fa 100644
static void
wifi_private_init (CEPageWifi *self)
{
-@@ -244,22 +250,16 @@ mode_combo_changed_cb (GtkComboBox *combo,
+@@ -245,23 +251,17 @@ mode_combo_changed_cb (GtkComboBox *combo,
CEPageWifiPrivate *priv = CE_PAGE_WIFI_GET_PRIVATE (self);
CEPage *parent = CE_PAGE (self);
GtkWidget *widget_band_label, *widget_chan_label, *widget_bssid_label;
@@ -65,11 +65,13 @@ index d0a5617..17db2fa 100644
widget_bssid_label = GTK_WIDGET (gtk_builder_get_object (parent->builder, "wifi_bssid_label"));
- if (adhoc) {
+- /* For Ad-Hoc show Band and Channel */
+ if (WIFI_MODE_ADHOC == wifi_mode || WIFI_MODE_AP == wifi_mode) {
- /* For Ad-Hoc show Band and Channel */
++ /* For Ad-Hoc/AP show Band and Channel */
gtk_widget_show (widget_band_label);
gtk_widget_show (GTK_WIDGET (priv->band));
-@@ -283,12 +283,13 @@ mode_combo_changed_cb (GtkComboBox *combo,
+ gtk_widget_show (widget_chan_label);
+@@ -284,12 +284,13 @@ mode_combo_changed_cb (GtkComboBox *combo,
gtk_widget_show (GTK_WIDGET (priv->bssid));
}
@@ -104,14 +106,15 @@ index d0a5617..17db2fa 100644
mode_combo_changed_cb (priv->mode, self);
g_signal_connect (priv->mode, "changed", G_CALLBACK (mode_combo_changed_cb), self);
g_free (mode);
-@@ -510,14 +514,18 @@ ui_to_setting (CEPageWifi *self)
+@@ -506,6 +510,7 @@ ui_to_setting (CEPageWifi *self)
GByteArray *bssid = NULL;
GByteArray *device_mac = NULL;
GByteArray *cloned_mac = NULL;
+ gint wifi_mode;
+ char *ifname = NULL;
const char *mode;
const char *band;
- GtkWidget *entry;
+@@ -516,8 +521,11 @@ ui_to_setting (CEPageWifi *self)
ssid = ce_page_wifi_get_ssid (self);
@@ -125,4 +128,5 @@ index d0a5617..17db2fa 100644
mode = "infrastructure";
--
-1.9.1
+2.1.0
+
diff --git a/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.0.2.bb b/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.0.4.bb
index 210b5b2b0c..d5e106c993 100644
--- a/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.0.2.bb
+++ b/meta-gnome/recipes-connectivity/network-manager-applet/network-manager-applet_1.0.4.bb
@@ -12,8 +12,8 @@ SRC_URI += " \
file://0001-Add-support-for-AP-mode-setting-for-wifi-sharing.patch \
file://0002-Use-AP-mode-for-network-sharing-if-device-supports-it.patch \
"
-SRC_URI[archive.md5sum] = "5b2a8baa6b038b3e55e5444ff321e80d"
-SRC_URI[archive.sha256sum] = "760af85b43fa5bcf74b96f899a6d4c1d5e9445e5eb63088c49e5164bbf88d9a9"
+SRC_URI[archive.md5sum] = "7fc2ed3f0c46ed41ddabe99d51513b1c"
+SRC_URI[archive.sha256sum] = "2cc26f03d0011d2a067bd5205dc0c17d5aa0470020a8c36d319ae10e5728af72"
PACKAGECONFIG[bluetooth] = "--with-bluetooth,--without-bluetooth,gnome-bluetooth,gnome-bluetooth"
PACKAGECONFIG[modemmanager] = "--with-modem-manager-1,--without-modem-manager-1,modemmanager"