aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-apps
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-12-02 09:32:57 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2012-12-11 01:52:53 +0100
commit2d44b0925ea368ddbee790925e9a432356a8eedd (patch)
treec40acfe670818edf4392389c10ec7dfe23c77423 /meta-gnome/recipes-apps
parent8c9b3585d955b22ce810a639f50ce094c5e49572 (diff)
downloadmeta-openembedded-contrib-2d44b0925ea368ddbee790925e9a432356a8eedd.tar.gz
epdfview: move from meta-efl to meta-gnome
* as suggested in http://lists.linuxtogo.org/pipermail/openembedded-devel/2012-November/042449.html Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-gnome/recipes-apps')
-rw-r--r--meta-gnome/recipes-apps/epdfview/epdfview/browser_command.patch17
-rw-r--r--meta-gnome/recipes-apps/epdfview/epdfview/fix-format.patch19
-rw-r--r--meta-gnome/recipes-apps/epdfview/epdfview/glib-single-include.patch17
-rw-r--r--meta-gnome/recipes-apps/epdfview/epdfview/swap-colors.patch43
-rw-r--r--meta-gnome/recipes-apps/epdfview/epdfview_0.1.8.bb21
5 files changed, 117 insertions, 0 deletions
diff --git a/meta-gnome/recipes-apps/epdfview/epdfview/browser_command.patch b/meta-gnome/recipes-apps/epdfview/epdfview/browser_command.patch
new file mode 100644
index 0000000000..75e45e0ab6
--- /dev/null
+++ b/meta-gnome/recipes-apps/epdfview/epdfview/browser_command.patch
@@ -0,0 +1,17 @@
+Imported from Debian 0.1.8-3
+
+Upstream-Status: Pending
+
+diff --git a/src/Config.cxx b/src/Config.cxx
+index 28f37ab..bc58819 100644
+--- a/src/Config.cxx
++++ b/src/Config.cxx
+@@ -22,7 +22,7 @@
+ using namespace ePDFView;
+
+ // Constants
+-static const gchar *DEFAULT_EXTERNAL_BROWSER_COMMAND_LINE = "firefox %s";
++static const gchar *DEFAULT_EXTERNAL_BROWSER_COMMAND_LINE = "x-www-browser %s";
+ static const gchar *DEFAULT_OPEN_FILE_FOLDER = NULL;
+ static const gchar *DEFAULT_SAVE_FILE_FOLDER = NULL;
+ static const gboolean DEFAULT_SHOW_STATUSBAR = TRUE;
diff --git a/meta-gnome/recipes-apps/epdfview/epdfview/fix-format.patch b/meta-gnome/recipes-apps/epdfview/epdfview/fix-format.patch
new file mode 100644
index 0000000000..8ad5b97ca9
--- /dev/null
+++ b/meta-gnome/recipes-apps/epdfview/epdfview/fix-format.patch
@@ -0,0 +1,19 @@
+Imported from Debian 0.1.8-3
+
+Upstream-Status: Pending
+
+diff --git a/src/gtk/MainView.cxx b/src/gtk/MainView.cxx
+index b983bff..f87de28 100644
+--- a/src/gtk/MainView.cxx
++++ b/src/gtk/MainView.cxx
+@@ -634,8 +634,9 @@ MainView::showErrorMessage (const gchar *title, const gchar *body)
+ GTK_DIALOG_DESTROY_WITH_PARENT,
+ GTK_MESSAGE_ERROR,
+ GTK_BUTTONS_OK,
++ "%s",
+ title);
+- gtk_message_dialog_format_secondary_text (GTK_MESSAGE_DIALOG(errorDialog),
++ gtk_message_dialog_format_secondary_text (GTK_MESSAGE_DIALOG(errorDialog), "%s",
+ body);
+ gtk_dialog_run (GTK_DIALOG (errorDialog));
+ gtk_widget_destroy (errorDialog);
diff --git a/meta-gnome/recipes-apps/epdfview/epdfview/glib-single-include.patch b/meta-gnome/recipes-apps/epdfview/epdfview/glib-single-include.patch
new file mode 100644
index 0000000000..84a4913863
--- /dev/null
+++ b/meta-gnome/recipes-apps/epdfview/epdfview/glib-single-include.patch
@@ -0,0 +1,17 @@
+Imported from Debian 0.1.8-3
+
+Upstream-Status: Pending
+
+diff --git a/src/gtk/StockIcons.h b/src/gtk/StockIcons.h
+index c142a7a..58fcf2e 100644
+--- a/src/gtk/StockIcons.h
++++ b/src/gtk/StockIcons.h
+@@ -18,7 +18,7 @@
+ #if !defined (__STOCK_ICONS_H__)
+ #define __STOCK_ICONS_H__
+
+-#include <glib/gmacros.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+
diff --git a/meta-gnome/recipes-apps/epdfview/epdfview/swap-colors.patch b/meta-gnome/recipes-apps/epdfview/epdfview/swap-colors.patch
new file mode 100644
index 0000000000..282bfb184a
--- /dev/null
+++ b/meta-gnome/recipes-apps/epdfview/epdfview/swap-colors.patch
@@ -0,0 +1,43 @@
+Imported from Debian 0.1.8-3
+
+Upstream-Status: Pending
+
+Index: trunk/src/PDFDocument.cxx
+===================================================================
+--- trunk/src/PDFDocument.cxx (revision 361)
++++ trunk/src/PDFDocument.cxx (revision 367)
+@@ -21,4 +21,5 @@
+ #include <poppler.h>
+ #include <unistd.h>
++#include <algorithm>
+ #include "epdfview.h"
+
+@@ -33,4 +34,22 @@
+ static PageMode convertPageMode (gint pageMode);
+ static gchar *getAbsoluteFileName (const gchar *fileName);
++
++namespace
++{
++ void
++ convert_bgra_to_rgba (guint8 *data, int width, int height)
++ {
++ using std::swap;
++
++ for (int y = 0; y < height; y++)
++ {
++ for (int x = 0; x < width; x++)
++ {
++ swap(data[0], data[2]);
++ data += 4;
++ }
++ }
++ }
++}
+
+ ///
+@@ -651,4 +670,5 @@
+ cairo_destroy(context);
+ cairo_surface_destroy (surface);
++ convert_bgra_to_rgba(renderedPage->getData (), width, height);
+ #else // !HAVE_POPPLER_0_17_0
+ // Create the pixbuf from the data and render to it.
diff --git a/meta-gnome/recipes-apps/epdfview/epdfview_0.1.8.bb b/meta-gnome/recipes-apps/epdfview/epdfview_0.1.8.bb
new file mode 100644
index 0000000000..53951e1d28
--- /dev/null
+++ b/meta-gnome/recipes-apps/epdfview/epdfview_0.1.8.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "A lightweight PDF viewer based on gtk and poppler"
+HOMEPAGE = "http://www.emma-soft.com/projects/epdfview/"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
+SECTION = "x11/applications"
+DEPENDS = "gtk+ poppler"
+
+PR = "r3"
+
+EXTRA_OECONF += "--without-cups"
+
+inherit autotools gettext
+
+SRC_URI = "http://www.emma-soft.com/projects/${BPN}/chrome/site/releases/${BP}.tar.bz2 \
+ file://browser_command.patch \
+ file://fix-format.patch \
+ file://glib-single-include.patch \
+ file://swap-colors.patch \
+"
+SRC_URI[md5sum] = "e50285b01612169b2594fea375f53ae4"
+SRC_URI[sha256sum] = "948648ae7c9d7b3b408d738bd4f48d87375b1196cae1129d6b846a8de0f2f8f0"