aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-02-01 23:04:58 -0800
committerKhem Raj <raj.khem@gmail.com>2019-02-03 10:46:42 -0800
commit78f210eb38c8d9d66f4ee2ea5525e865f9350b78 (patch)
treedab748dec96b71156499b13eae5a22f45aed0fc8 /meta-filesystems
parentfe157b9cb9b6c2954d8c92b66afd167676d31ea1 (diff)
downloadmeta-openembedded-contrib-78f210eb38c8d9d66f4ee2ea5525e865f9350b78.tar.gz
owfs: Inherit systemd
Fix ERROR: QA Issue: owfs: Files/directories were installed but not shipped in any package: /lib /lib/systemd /lib/systemd/system /lib/systemd/system/owfs.service /lib/systemd/system/owftpd.service /lib/systemd/system/owhttpd.service /lib/systemd/system/owserver.service /lib/systemd/system/owserver.socket Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-filesystems/owfs/owfs_3.2p2.bb17
1 files changed, 13 insertions, 4 deletions
diff --git a/meta-filesystems/recipes-filesystems/owfs/owfs_3.2p2.bb b/meta-filesystems/recipes-filesystems/owfs/owfs_3.2p2.bb
index 50865cccda..857aaf216d 100644
--- a/meta-filesystems/recipes-filesystems/owfs/owfs_3.2p2.bb
+++ b/meta-filesystems/recipes-filesystems/owfs/owfs_3.2p2.bb
@@ -18,7 +18,7 @@ SRC_URI = "git://github.com/owfs/owfs \
S = "${WORKDIR}/git"
-inherit autotools-brokensep update-rc.d pkgconfig
+inherit autotools-brokensep update-rc.d pkgconfig systemd
EXTRA_OECONF = " \
--with-fuseinclude=${STAGING_INCDIR} \
@@ -52,9 +52,12 @@ DESCRIPTION_libownet = "easy C-language 1-wire interface to the owserver protoco
DESCRIPTION_owmon = "Monitor for owserver settings and statistics"
DESCRIPTION_owtap = "Packet sniffer for the owserver protocol"
-FILES_owftpd = "${bindir}/owftpd"
-FILES_owhttpd = "${bindir}/owhttpd ${sysconfdir}/init.d/owhttpd"
-FILES_owserver = "${bindir}/owserver ${sysconfdir}/init.d/owserver"
+FILES_owftpd = "${bindir}/owftpd ${systemd_system_unitdir}/owftpd.service"
+FILES_owhttpd = "${bindir}/owhttpd ${sysconfdir}/init.d/owhttpd \
+ ${systemd_system_unitdir}/owhttpd.service"
+FILES_owserver = "${bindir}/owserver ${sysconfdir}/init.d/owserver \
+ ${systemd_system_unitdir}/owserver.service \
+ ${systemd_system_unitdir}/owserver.socket"
FILES_owshell = "${bindir}/owread ${bindir}/owwrite \
${bindir}/owdir ${bindir}/owpresent \
${bindir}/owget ${bindir}/owside"
@@ -63,9 +66,15 @@ FILES_owtap = "${bindir}/owtap"
FILES_libowcapi = "${libdir}/libowcapi-*"
FILES_libow = "${libdir}/libow-*"
FILES_libownet = "${libdir}/libownet-*"
+FILES_${PN} += "${systemd_system_unitdir}/owfs.service"
INITSCRIPT_PACKAGES = "owhttpd owserver"
INITSCRIPT_NAME_owserver = "owserver"
INITSCRIPT_NAME_owhttpd = "owhttpd"
INITSCRIPT_PARAMS_owserver = "defaults 20"
INITSCRIPT_PARAMS_owhttpd = "defaults 21"
+
+SYSTEMD_SERVICE_${PN} = "owfs.service"
+SYSTEMD_SERVICE_${PN}-owftpd = "owftpd.service"
+SYSTEMD_SERVICE_${PN}-owhttpd = "owhttpd.service"
+SYSTEMD_SERVICE_${PN}-owserver = "owserver.service owserver.socket"