aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-09-18 00:05:10 +0800
committerKhem Raj <raj.khem@gmail.com>2018-09-17 22:23:29 -0700
commited779d3f1b068fc9ba91080215097646f4de3c53 (patch)
tree18cc6eaeb6123290291d306e906ec1f84d2568a3 /meta-filesystems
parent94f4f52101db6d6a45f88ea40240dd5ea3330ff3 (diff)
downloadmeta-openembedded-contrib-ed779d3f1b068fc9ba91080215097646f4de3c53.tar.gz
fuse: split one dpg package only
Multiple -dbg packages per recipe is not encouraged, and only one is recommended and the code only works properly in some cases for one. Add RPROVIDES_${PN}-dbg to be compatiable with previous dbg packages requiring. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-support/fuse/fuse_2.9.8.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-filesystems/recipes-support/fuse/fuse_2.9.8.bb b/meta-filesystems/recipes-support/fuse/fuse_2.9.8.bb
index 1815aa59c7..caa75c7f53 100644
--- a/meta-filesystems/recipes-support/fuse/fuse_2.9.8.bb
+++ b/meta-filesystems/recipes-support/fuse/fuse_2.9.8.bb
@@ -31,7 +31,9 @@ SYSTEMD_SERVICE_${PN} = ""
DEPENDS = "gettext-native"
-PACKAGES =+ "fuse-utils-dbg fuse-utils libulockmgr libulockmgr-dev libulockmgr-dbg"
+PACKAGES =+ "fuse-utils libulockmgr libulockmgr-dev"
+
+RPROVIDES_${PN}-dbg += "fuse-utils-dbg libulockmgr-dbg"
RRECOMMENDS_${PN}_class-target = "kernel-module-fuse libulockmgr fuse-utils"
@@ -40,13 +42,11 @@ FILES_${PN}-dev += "${libdir}/libfuse*.la"
FILES_libulockmgr = "${libdir}/libulockmgr.so.*"
FILES_libulockmgr-dev += "${libdir}/libulock*.la"
-FILES_libulockmgr-dbg += "${libdir}/.debug/libulock*"
# Forbid auto-renaming to libfuse-utils
FILES_fuse-utils = "${bindir} ${base_sbindir}"
-FILES_fuse-utils-dbg = "${bindir}/.debug ${base_sbindir}/.debug"
DEBIAN_NOAUTONAME_fuse-utils = "1"
-DEBIAN_NOAUTONAME_fuse-utils-dbg = "1"
+DEBIAN_NOAUTONAME_${PN}-dbg = "1"
do_configure_prepend() {
# Make this explicit so overriding base_sbindir propagates properly.