aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorTom Hayward <tom@harbortronics.com>2017-03-02 13:01:40 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-07 13:29:45 +0100
commitf291c5e076e907a0b80cfc4f4967d90fdd9b46de (patch)
treeed46cac6c72d4b3e12352c9ac8fb638208321a08 /meta-filesystems
parentcd5b07e5a81502415ebdd7d3fbee0b35aa7a5c61 (diff)
downloadmeta-openembedded-contrib-f291c5e076e907a0b80cfc4f4967d90fdd9b46de.tar.gz
fuse-exfat: fix mount detection of mount.exfat
When package was switched to autotools, "DESTDIR=${D}/${base_sbindir}" was removed from the recipe. This left the installation target as sbindir (/usr/sbin/). This breaks `mount -t exfat /dev/sda1 /media/sda1`, because mount only searches for mount.exfat in /sbin/, /sbin/fs.d/, and /sbin/fs/. With sbindir = "${base_sbindir}", mount.exfat is installed at /sbin/mount.exfat where mount can find it. Signed-off-by: Tom Hayward <tom@harbortronics.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-filesystems/fuse-exfat/fuse-exfat_1.2.3.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-filesystems/fuse-exfat/fuse-exfat_1.2.3.bb b/meta-filesystems/recipes-filesystems/fuse-exfat/fuse-exfat_1.2.3.bb
index 639e33cfab..99bf2bed41 100644
--- a/meta-filesystems/recipes-filesystems/fuse-exfat/fuse-exfat_1.2.3.bb
+++ b/meta-filesystems/recipes-filesystems/fuse-exfat/fuse-exfat_1.2.3.bb
@@ -18,3 +18,4 @@ SRC_URI[md5sum] = "fca71e6598f79d037a3c7c969cb5710c"
SRC_URI[sha256sum] = "f2e06eba5a21c621aac1d6da21b12a5a324fdd1e20f9c8acd357dd463c2355d9"
S = "${WORKDIR}/${PN}-${PV}"
+EXTRA_OECONF += "sbindir=${base_sbindir}"