aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-09-27 07:55:33 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-03 19:19:57 +0200
commit3bbec2b7921c83e13b64e808ef34122a608933f0 (patch)
tree08893f3b855fa8b606dd06c52ad3312521526c1c /meta-filesystems
parenta0c3cea1ca5f9231a498a9dedd6eb18ee41b1d5a (diff)
downloadmeta-openembedded-contrib-3bbec2b7921c83e13b64e808ef34122a608933f0.tar.gz
physfs: move to sources found at github/supertux
* It seems that physfs is still maintained there and has the functionality required by latest supertux. * License changed Copyright year causing checksum change. Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems')
-rw-r--r--meta-filesystems/recipes-support/physfs/files/0001-fix-build-with-gcc-6.patch52
-rw-r--r--meta-filesystems/recipes-support/physfs/physfs_2.0.3.bb11
-rw-r--r--meta-filesystems/recipes-support/physfs/physfs_git.bb15
3 files changed, 67 insertions, 11 deletions
diff --git a/meta-filesystems/recipes-support/physfs/files/0001-fix-build-with-gcc-6.patch b/meta-filesystems/recipes-support/physfs/files/0001-fix-build-with-gcc-6.patch
new file mode 100644
index 0000000000..805c4a1f0e
--- /dev/null
+++ b/meta-filesystems/recipes-support/physfs/files/0001-fix-build-with-gcc-6.patch
@@ -0,0 +1,52 @@
+From 06fe4c205094e0b65d3e5d1244f52089ed5bdafb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
+Date: Sun, 25 Sep 2016 23:50:22 +0200
+Subject: [PATCH] fix build with gcc-6
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Upstream-Status: Pending
+
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+---
+ src/archiver_zip.c | 1 -
+ src/physfs_miniz.h | 3 +++
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/src/archiver_zip.c b/src/archiver_zip.c
+index 5c4996d..3b436db 100644
+--- a/src/archiver_zip.c
++++ b/src/archiver_zip.c
+@@ -845,7 +845,6 @@ static ZIPentry *zip_hash_ancestors(ZIPinfo *info, char *name)
+ if (sep)
+ {
+ const size_t namelen = (sep - name) + 1;
+- ZIPentry *parent;
+
+ *sep = '\0'; /* chop off last piece. */
+ retval = zip_find_entry(info, name);
+diff --git a/src/physfs_miniz.h b/src/physfs_miniz.h
+index 619cb71..fd877c0 100644
+--- a/src/physfs_miniz.h
++++ b/src/physfs_miniz.h
+@@ -194,6 +194,8 @@ struct tinfl_decompressor_tag
+ code_len = TINFL_FAST_LOOKUP_BITS; do { temp = (pHuff)->m_tree[~temp + ((bit_buf >> code_len++) & 1)]; } while (temp < 0); \
+ } sym = temp; bit_buf >>= code_len; num_bits -= code_len; } MZ_MACRO_END
+
++#pragma GCC diagnostic push
++#pragma GCC diagnostic ignored "-Wmisleading-indentation"
+ static tinfl_status tinfl_decompress(tinfl_decompressor *r, const mz_uint8 *pIn_buf_next, size_t *pIn_buf_size, mz_uint8 *pOut_buf_start, mz_uint8 *pOut_buf_next, size_t *pOut_buf_size, const mz_uint32 decomp_flags)
+ {
+ static const int s_length_base[31] = { 3,4,5,6,7,8,9,10,11,13, 15,17,19,23,27,31,35,43,51,59, 67,83,99,115,131,163,195,227,258,0,0 };
+@@ -465,6 +467,7 @@ common_exit:
+ }
+ return status;
+ }
++#pragma GCC diagnostic pop
+
+ /* Flush values. For typical usage you only need MZ_NO_FLUSH and MZ_FINISH. The other stuff is for advanced use. */
+ enum { MZ_NO_FLUSH = 0, MZ_PARTIAL_FLUSH = 1, MZ_SYNC_FLUSH = 2, MZ_FULL_FLUSH = 3, MZ_FINISH = 4, MZ_BLOCK = 5 };
+--
+2.5.5
+
diff --git a/meta-filesystems/recipes-support/physfs/physfs_2.0.3.bb b/meta-filesystems/recipes-support/physfs/physfs_2.0.3.bb
deleted file mode 100644
index 5618f28a68..0000000000
--- a/meta-filesystems/recipes-support/physfs/physfs_2.0.3.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-SUMMARY = "PhysicsFS is a library to provide abstract access to various archives"
-HOMEAPAGE = "http://icculus.org/physfs"
-LICENSE = "Zlib"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5d94e3eaaa10b00ca803ba35a3e87cde"
-DEPENDS = "readline zlib"
-
-inherit cmake
-
-SRC_URI = "http://icculus.org/${BPN}/downloads/${BP}.tar.bz2"
-SRC_URI[md5sum] = "c2c727a8a8deb623b521b52d0080f613"
-SRC_URI[sha256sum] = "ca862097c0fb451f2cacd286194d071289342c107b6fe69079c079883ff66b69"
diff --git a/meta-filesystems/recipes-support/physfs/physfs_git.bb b/meta-filesystems/recipes-support/physfs/physfs_git.bb
new file mode 100644
index 0000000000..a50715ce01
--- /dev/null
+++ b/meta-filesystems/recipes-support/physfs/physfs_git.bb
@@ -0,0 +1,15 @@
+SUMMARY = "PhysicsFS is a library to provide abstract access to various archives"
+HOMEAPAGE = "http://icculus.org/physfs"
+LICENSE = "Zlib"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4424d2cfb8a288df2843c4467b5d719a"
+DEPENDS = "readline zlib"
+
+inherit cmake
+
+SRC_URI = " \
+ git://github.com/SuperTux/physfs.git \
+ file://0001-fix-build-with-gcc-6.patch \
+"
+SRCREV = "f3b45a94d0b7c0a85469b1e60fefd8383b6719ba"
+S = "${WORKDIR}/git"
+PV = "2.0.3+git${SRCPV}"