aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-utils
diff options
context:
space:
mode:
authorPeter Kjellerstedt <pkj@axis.com>2024-02-15 21:06:35 +0100
committerKhem Raj <raj.khem@gmail.com>2024-02-15 14:14:27 -0800
commite3785b50fd7d7187e284697a5f81286ad55eeeb0 (patch)
treec52541d9fb0efc0e855d421d417557ec023023fb /meta-filesystems/recipes-utils
parent7e0ce9b5e7e0e574acbf3488c947693e52c45f9f (diff)
downloadmeta-openembedded-contrib-e3785b50fd7d7187e284697a5f81286ad55eeeb0.tar.gz
xfstests: Only specify the main SRCREV once
The "update" in commit 2af7d3f63e added a SRCREV rather than updating SRCREV_xfstests. Change the recipe to actually use SRCREV so that it is compatible with future AUH updates. Also replace "/usr" with "${prefix}". Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems/recipes-utils')
-rw-r--r--meta-filesystems/recipes-utils/xfstests/xfstests_2024.01.14.bb20
1 files changed, 8 insertions, 12 deletions
diff --git a/meta-filesystems/recipes-utils/xfstests/xfstests_2024.01.14.bb b/meta-filesystems/recipes-utils/xfstests/xfstests_2024.01.14.bb
index 5ff1914569..2800a4c30f 100644
--- a/meta-filesystems/recipes-utils/xfstests/xfstests_2024.01.14.bb
+++ b/meta-filesystems/recipes-utils/xfstests/xfstests_2024.01.14.bb
@@ -2,19 +2,17 @@ SUMMARY = "File system QA test suite"
LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=74274e8a218423e49eefdea80bc55038"
-SRCREV = "11914614784735c504f43b5b6baabaa713375984"
-SRCREV_FORMAT = "xfstests_unionmount"
+SRCREV = "c46ca4d1f6c0c45f9a3ea18bc31ba5ae89e02c70"
+SRCREV_unionmount = "e3825b16b46f4c4574a1a69909944c059835f914"
+SRCREV_FORMAT = "default_unionmount"
-SRC_URI = "git://git.kernel.org/pub/scm/fs/xfs/xfstests-dev.git;branch=master;name=xfstests \
+SRC_URI = "git://git.kernel.org/pub/scm/fs/xfs/xfstests-dev.git;branch=master \
git://github.com/amir73il/unionmount-testsuite.git;branch=master;protocol=https;name=unionmount;destsuffix=unionmount-testsuite \
file://0001-add-missing-FTW_-macros-when-not-available-in-libc.patch \
file://0002-Drop-detached_mounts_propagation-and-remove-sys-moun.patch \
file://0003-tests-Makefile-make-sure-group.list-DIRT-exists-befo.patch \
"
-SRCREV_xfstests = "c46ca4d1f6c0c45f9a3ea18bc31ba5ae89e02c70"
-SRCREV_unionmount = "e3825b16b46f4c4574a1a69909944c059835f914"
-
S = "${WORKDIR}/git"
# brokensep because m4/package_globals.m4 calls ". ./VERSION" (and that's not the only issue)
@@ -57,14 +55,12 @@ do_install() {
export DIST_ROOT="/" DIST_MANIFEST="" DESTDIR="${D}"
oe_runmake install
- unionmount_target_dir=${D}/usr/xfstests/unionmount-testsuite
- install -d ${D}/usr/xfstests/unionmount-testsuite/tests
- install -D ${WORKDIR}/unionmount-testsuite/tests/* -t $unionmount_target_dir/tests
+ unionmount_target_dir=${D}${prefix}/xfstests/unionmount-testsuite
+ install -d $unionmount_target_dir/tests
+ install ${WORKDIR}/unionmount-testsuite/tests/* -t $unionmount_target_dir/tests
install ${WORKDIR}/unionmount-testsuite/*.py -t $unionmount_target_dir
install ${WORKDIR}/unionmount-testsuite/run -t $unionmount_target_dir
install ${WORKDIR}/unionmount-testsuite/README -t $unionmount_target_dir
}
-FILES:${PN} += "\
- /usr/xfstests \
-"
+FILES:${PN} += "${prefix}/xfstests"