aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.2.3.bb
diff options
context:
space:
mode:
authorJianchuan Wang <jianchuan.wang@windriver.com>2015-07-29 10:46:59 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-18 11:38:02 +0200
commit8979be15071a7c6f53371d0cbe209362c9620a45 (patch)
tree339aa343efb0f35647ba2bc81de3929eccc34d68 /meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.2.3.bb
parent175fb665516874a0b196efd9a77795ee70083c68 (diff)
downloadmeta-openembedded-contrib-8979be15071a7c6f53371d0cbe209362c9620a45.tar.gz
xfsprogs: Uprev to 3.2.3 version
In the v3.2.3, the libhandle.so/libhandle.a paths have changed so that We need not rm them in the install processing. Signed-off-by: Jianchuan Wang <jianchuan.wang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.2.3.bb')
-rw-r--r--meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.2.3.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.2.3.bb b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.2.3.bb
new file mode 100644
index 0000000000..8df7bc12e6
--- /dev/null
+++ b/meta-filesystems/recipes-utils/xfsprogs/xfsprogs_3.2.3.bb
@@ -0,0 +1,52 @@
+SUMMARY = "XFS Filesystem Utilities"
+HOMEPAGE = "http://oss.sgi.com/projects/xfs"
+SECTION = "base"
+LICENSE = "GPLv2"
+LICENSE_libhandle = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://doc/COPYING;md5=dbdb5f4329b7e7145de650e9ecd4ac2a"
+DEPENDS = "util-linux"
+
+SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/${BP}.tar.gz \
+ file://xfsprogs-generate-crctable-which-is-moved-into-runti.patch \
+ file://remove-install-as-user.patch \
+ file://drop-configure-check-for-aio.patch \
+"
+
+SRC_URI[md5sum] = "9f383e36682709e62b12c125e5d8b895"
+SRC_URI[sha256sum] = "7a5124a880997939551b519610a2e54bd4cd0b0adfd563ce3f4de30827109ac9"
+
+inherit autotools-brokensep
+
+PACKAGES =+ "${PN}-fsck ${PN}-mkfs libhandle"
+
+RDEPENDS_${PN} = "${PN}-fsck ${PN}-mkfs"
+
+FILES_${PN}-fsck = "${base_sbindir}/fsck.xfs"
+FILES_${PN}-mkfs = "${base_sbindir}/mkfs.xfs"
+FILES_libhandle = "${base_libdir}/libhandle${SOLIBS}"
+
+EXTRA_OECONF = "--enable-gettext=no"
+do_configure () {
+ # Prevent Makefile from calling configure without arguments,
+ # when do_configure gets called for a second time.
+ rm -f include/builddefs include/platform_defs.h
+ # Recreate configure script.
+ rm -f configure
+ oe_runmake configure
+ # Configure.
+ export DEBUG="-DNDEBUG"
+ gnu-configize --force
+ oe_runconf
+}
+
+LIBTOOL = "${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
+TARGET_CC_ARCH += "${LDFLAGS}"
+PARALLEL_MAKE = ""
+
+do_install () {
+ export DIST_ROOT=${D}
+ oe_runmake install
+ # needed for xfsdump
+ oe_runmake install-dev
+}