aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-support
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2024-05-10 07:47:08 +0200
committerKhem Raj <raj.khem@gmail.com>2024-05-19 08:27:51 -0700
commit7cceba0e2cbe5b045c1dc175cfdfefd7fbd3bc62 (patch)
treef873f01541bce368873f89e89d6ae833692638b2 /meta-filesystems/recipes-support
parentc16704f6a38dabfccc7a0651fa9ba4c67b6f510a (diff)
downloadmeta-openembedded-contrib-7cceba0e2cbe5b045c1dc175cfdfefd7fbd3bc62.tar.gz
fuse3: move from meta-filesystems to meta-oe
Technically flatpak and xdg-desktop-portal have a runtime dependency on fuse3-utils. I was worried that adding it might cause problems with CI since fuse3 is not included in meta-oe. Given that both packages also require fuse3 at buildtime it could be a good idea to move fuse3 to avoid a meta-filesystems dependency for meta-oe Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-filesystems/recipes-support')
-rw-r--r--meta-filesystems/recipes-support/fuse/fuse3/run-ptest3
-rw-r--r--meta-filesystems/recipes-support/fuse/fuse3_3.16.2.bb84
2 files changed, 0 insertions, 87 deletions
diff --git a/meta-filesystems/recipes-support/fuse/fuse3/run-ptest b/meta-filesystems/recipes-support/fuse/fuse3/run-ptest
deleted file mode 100644
index b63c4de0d9..0000000000
--- a/meta-filesystems/recipes-support/fuse/fuse3/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-filesystems/recipes-support/fuse/fuse3_3.16.2.bb b/meta-filesystems/recipes-support/fuse/fuse3_3.16.2.bb
deleted file mode 100644
index 2b0797a6f5..0000000000
--- a/meta-filesystems/recipes-support/fuse/fuse3_3.16.2.bb
+++ /dev/null
@@ -1,84 +0,0 @@
-SUMMARY = "Implementation of a fully functional filesystem in a userspace program"
-DESCRIPTION = "FUSE (Filesystem in Userspace) is a simple interface for userspace \
- programs to export a virtual filesystem to the Linux kernel. FUSE \
- also aims to provide a secure method for non privileged users to \
- create and mount their own filesystem implementations. \
- "
-HOMEPAGE = "https://github.com/libfuse/libfuse"
-SECTION = "libs"
-LICENSE = "GPL-2.0-only & LGPL-2.0-only"
-LIC_FILES_CHKSUM = " \
- file://GPL2.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
- file://LGPL2.txt;md5=4fbd65380cdd255951079008b364516c \
- file://LICENSE;md5=a55c12a2d7d742ecb41ca9ae0a6ddc66 \
-"
-
-SRC_URI = "https://github.com/libfuse/libfuse/releases/download/fuse-${PV}/fuse-${PV}.tar.gz \
-"
-SRC_URI[sha256sum] = "f797055d9296b275e981f5f62d4e32e089614fc253d1ef2985851025b8a0ce87"
-
-S = "${WORKDIR}/fuse-${PV}"
-
-UPSTREAM_CHECK_URI = "https://github.com/libfuse/libfuse/releases"
-UPSTREAM_CHECK_REGEX = "fuse\-(?P<pver>3(\.\d+)+).tar.xz"
-
-CVE_PRODUCT = "fuse_project:fuse"
-
-inherit meson pkgconfig ptest
-
-SRC_URI += " \
- file://run-ptest \
-"
-
-RDEPENDS:${PN}-ptest += " \
- python3-pytest \
- python3-looseversion \
- bash \
-"
-RRECOMMENDS:${PN}-ptest += " kernel-module-cuse"
-
-do_install_ptest() {
- install -d ${D}${PTEST_PATH}/test
- install -d ${D}${PTEST_PATH}/example
- install -d ${D}${PTEST_PATH}/util
- cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
-
- example_excutables=`find ${B}/example -type f -executable`
- util_excutables=`find ${B}/util -type f -executable`
- test_excutables=`find ${B}/test -type f -executable`
-
- for e in $example_excutables
- do
- cp -rf $e ${D}${PTEST_PATH}/example/
- done
-
- for e in $util_excutables
- do
- cp -rf $e ${D}${PTEST_PATH}/util/
- done
-
- for e in $test_excutables
- do
- cp -rf $e ${D}${PTEST_PATH}/test
- done
-}
-
-DEPENDS = "udev"
-
-PACKAGES =+ "fuse3-utils"
-
-RPROVIDES:${PN}-dbg += "fuse3-utils-dbg"
-
-RRECOMMENDS:${PN}:class-target = "kernel-module-fuse fuse3-utils"
-
-FILES:${PN} += "${libdir}/libfuse3.so.*"
-FILES:${PN}-dev += "${libdir}/libfuse3*.la"
-
-# Forbid auto-renaming to libfuse3-utils
-FILES:fuse3-utils = "${bindir} ${base_sbindir}"
-DEBIAN_NOAUTONAME:fuse3-utils = "1"
-DEBIAN_NOAUTONAME:${PN}-dbg = "1"
-
-do_install:append() {
- rm -rf ${D}${base_prefix}/dev
-}