aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-08-13 14:00:32 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-23 13:36:20 +0200
commita8d31694852bc0d0d4069b4fb9f4fde6625e47f7 (patch)
tree0673bd226f21ad53f0e3c6d38697d0ee15fed312 /meta-efl
parentfaf83c51dd4e79419e5dd1abfba96c26a09ac982 (diff)
downloadmeta-openembedded-contrib-a8d31694852bc0d0d4069b4fb9f4fde6625e47f7.tar.gz
efl: upgrade to 1.11.0
* announcement: https://phab.enlightenment.org/phame/post/view/74/ https://phab.enlightenment.org/phame/post/view/77/ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl')
-rw-r--r--meta-efl/recipes-efl/efl/efl.inc15
-rw-r--r--meta-efl/recipes-efl/efl/efl_1.11.0.bb (renamed from meta-efl/recipes-efl/efl/efl_1.10.2.bb)4
-rw-r--r--meta-efl/recipes-efl/efl/elementary.inc3
-rw-r--r--meta-efl/recipes-efl/efl/elementary_1.11.0.bb (renamed from meta-efl/recipes-efl/efl/elementary_1.10.2.bb)4
-rw-r--r--meta-efl/recipes-efl/efl/emotion-generic-players_1.10.0.bb8
-rw-r--r--meta-efl/recipes-efl/efl/emotion-generic-players_1.11.0.bb8
-rw-r--r--meta-efl/recipes-efl/efl/evas-generic-loaders_1.10.0.bb8
-rw-r--r--meta-efl/recipes-efl/efl/evas-generic-loaders_1.11.0.bb8
8 files changed, 35 insertions, 23 deletions
diff --git a/meta-efl/recipes-efl/efl/efl.inc b/meta-efl/recipes-efl/efl/efl.inc
index 648c5b6fb3..c82780b996 100644
--- a/meta-efl/recipes-efl/efl/efl.inc
+++ b/meta-efl/recipes-efl/efl/efl.inc
@@ -19,7 +19,7 @@ PROVIDES += "ecore edje eet eeze efreet eina eio embryo emotion ethumb evas eldb
# your own in terms of ensuring everything works if you do this
EXTRA_OECONF = " \
--disable-physics \
- --enable-i-really-know-what-i-am-doing-and-that-this-will-probably-break-things-and-i-will-fix-them-myself-and-send-patches-aaa \
+ --enable-i-really-know-what-i-am-doing-and-that-this-will-probably-break-things-and-i-will-fix-them-myself-and-send-patches-aba \
"
EXTRA_OECONF_append_class-target = " \
--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
@@ -53,20 +53,23 @@ PACKAGECONFIG[opengl-es] = "--with-opengl=es,,virtual/libgles2"
PACKAGECONFIG[opengl-none] = "--with-opengl=none,,"
# be aware when enabling this for efl-native, we don't provide gcc-native so you need to make
# sure that all your builders have g++ which supports -std=gnu++11
-PACKAGECONFIG[c++11] = "--enable-c++11,--disable-c++11"
+PACKAGECONFIG[c++11] = "--enable-cxx-bindings,--disable-cxx-bindings"
PACKAGECONFIG[gstreamer] = "--enable-gstreamer,--disable-gstreamer,gstreamer"
PACKAGECONFIG[gstreamer1] = "--enable-gstreamer1,--disable-gstreamer1,gstreamer1.0 gstreamer1.0-plugins-base"
PACKAGECONFIG[pulseaudio] = "--enable-pulseaudio,--disable-pulseaudio,pulseaudio"
PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
PACKAGECONFIG[luajit] = "--disable-lua-old,--enable-lua-old,luajit"
PACKAGECONFIG[lua-old] = "--enable-lua-old,--disable-lua-old,lua"
+PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi"
+# currently we don't provide doxygen-native
+PACKAGECONFIG[doc] = "--enable-doc,--disable-doc,doxygen-native"
# new efl doesn't have option to disable eeze build and we don't want to provide udev-native just to build eeze-native we don't need
do_configure_prepend_class-native() {
sed -i 's/EFL_LIB_START_OPTIONAL(\[Eeze\], \[test "${have_linux}" = "yes"\])/EFL_LIB_START_OPTIONAL([Eeze], [test "${no-we-really-dont-want-native-eeze}" = "yes"])/g' ${S}/configure.ac
}
-PACKAGES =+ "edje-utils embryo-utils embryo-tests efreet-trash efreet-mime libeet libefreet ecore-audio ecore-input-evas ecore-input ecore-imf-evas ecore-imf ecore-file ecore-con ecore-ipc ecore-x ecore-evas libemotion eo ecore edje eet eeze efreet eina eio embryo emotion ethumb evas eldbus"
+PACKAGES =+ "edje-utils embryo-utils embryo-tests efreet-trash efreet-mime libeet libefreet ecore-audio ecore-input-evas ecore-input ecore-imf-evas ecore-imf ecore-file ecore-con ecore-ipc ecore-x ecore-evas libemotion eo ecore edje eet eeze efreet eina eio embryo emotion ethumb evas eldbus elua"
# upgrade path from 1.7
DEBIAN_NOAUTONAME_ecore-audio = "1"
@@ -153,6 +156,7 @@ FILES_ecore-ipc = "\
"
FILES_ecore-x = "\
${libdir}/libecore_x${SOLIBS} \
+ ${libdir}/ecore_x/bin/v-*/ecore_x_vsync \
"
FILES_ecore-evas = "\
${libdir}/libecore_evas${SOLIBS} \
@@ -241,9 +245,14 @@ FILES_edje = " \
${datadir}/edje \
${datadir}/mime \
"
+FILES_elua = " \
+ ${bindir}/elua \
+ ${datadir}/elua \
+"
FILES_${PN}-dbg += " \
${libdir}/efreet/*/.debug \
${libdir}/ecore*/*/*/*/.debug \
+ ${libdir}/ecore*/*/*/.debug \
${libdir}/evas*/*/*/*/*/.debug \
${libdir}/evas/cserve2/bin/*/.debug \
${libdir}/eeze*/*/*/*/*/.debug \
diff --git a/meta-efl/recipes-efl/efl/efl_1.10.2.bb b/meta-efl/recipes-efl/efl/efl_1.11.0.bb
index 76a9ba7cf2..45ee389e70 100644
--- a/meta-efl/recipes-efl/efl/efl_1.10.2.bb
+++ b/meta-efl/recipes-efl/efl/efl_1.11.0.bb
@@ -4,8 +4,8 @@ SRC_URI = "\
${E_RELEASES}/libs/${SRCNAME}/${SRCNAME}-${SRCVER}.tar.gz \
"
-SRC_URI[md5sum] = "c74888bfdc774e69eac26978557a89bb"
-SRC_URI[sha256sum] = "44acf012f0dd3b0c01bb2c5e53231076d7ed463166f581d22ef441b127e8c85f"
+SRC_URI[md5sum] = "83a1e983d7e9d3efcbba9a7a29cad54d"
+SRC_URI[sha256sum] = "0a8ab66e012820cad7dd78de371f8dcbbd79cb316302e1e6c354181de35d727f"
# Temporary disable until error like the one following are fixed
# efl-native/2_1.8.4-r0/efl-1.8.4/src/lib/eet/.libs/libeet.so: file not recognized: File truncated
diff --git a/meta-efl/recipes-efl/efl/elementary.inc b/meta-efl/recipes-efl/efl/elementary.inc
index c22070f91b..c5e75b96c8 100644
--- a/meta-efl/recipes-efl/efl/elementary.inc
+++ b/meta-efl/recipes-efl/efl/elementary.inc
@@ -18,6 +18,9 @@ BBCLASSEXTEND = "native"
PACKAGECONFIG[eweather] = "--enable-eweather,--disable-eweather,libeweather"
PACKAGECONFIG[ewebkit] = "--with-elementary-web-backend=ewebkit,--with-elementary-web-backend=none,webkit-efl"
+# be aware when enabling this for efl-native, we don't provide gcc-native so you need to make
+# sure that all your builders have g++ which supports -std=gnu++11
+PACKAGECONFIG[c++11] = "--enable-cxx-bindings,--disable-cxx-bindings"
do_configure_prepend() {
# prefix returned eolian paths with STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly
diff --git a/meta-efl/recipes-efl/efl/elementary_1.10.2.bb b/meta-efl/recipes-efl/efl/elementary_1.11.0.bb
index eb182bbfe0..d188c23765 100644
--- a/meta-efl/recipes-efl/efl/elementary_1.10.2.bb
+++ b/meta-efl/recipes-efl/efl/elementary_1.11.0.bb
@@ -8,8 +8,8 @@ SRC_URI = "\
# these paths aren't passed in -native build
SRC_URI_append_class-target = " file://0001-Makefile-Use-elementary_codegen-defined-in-configure.patch"
-SRC_URI[md5sum] = "2ccc130e137319accd81ccf3d321905b"
-SRC_URI[sha256sum] = "48fcfbd66b90df8b21203307d66364fb1d773b3e979476116b2ad1a5eab67378"
+SRC_URI[md5sum] = "cfcf3b0620cbb6e86021286631274d9a"
+SRC_URI[sha256sum] = "47ee79f7fc4e355557e6809e2001468bc8e40939562e3a96f689969ab67c17b4"
# autotools-brokensep - configure updates Elementary.h correctly in ${B}, but then build is using Elementary.h from ${S}
# which includes #define ELM_EMAP (instead of #undef ELM_EMAP) and building fails
diff --git a/meta-efl/recipes-efl/efl/emotion-generic-players_1.10.0.bb b/meta-efl/recipes-efl/efl/emotion-generic-players_1.10.0.bb
deleted file mode 100644
index 5d5ed4b8c1..0000000000
--- a/meta-efl/recipes-efl/efl/emotion-generic-players_1.10.0.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require ${BPN}.inc
-
-SRC_URI = "\
- ${E_RELEASES}/libs/${SRCNAME}/${SRCNAME}-${SRCVER}.tar.gz \
-"
-
-SRC_URI[md5sum] = "f73b1f73b38a323e37bd138b103191a5"
-SRC_URI[sha256sum] = "ccfb1c8c346ba1a84484b82ce1ce871fd2c6660421ca7fa5d911661bd3cc94db"
diff --git a/meta-efl/recipes-efl/efl/emotion-generic-players_1.11.0.bb b/meta-efl/recipes-efl/efl/emotion-generic-players_1.11.0.bb
new file mode 100644
index 0000000000..4cb74f5e2d
--- /dev/null
+++ b/meta-efl/recipes-efl/efl/emotion-generic-players_1.11.0.bb
@@ -0,0 +1,8 @@
+require ${BPN}.inc
+
+SRC_URI = "\
+ ${E_RELEASES}/libs/${SRCNAME}/${SRCNAME}-${SRCVER}.tar.gz \
+"
+
+SRC_URI[md5sum] = "432febd580ed1a4d7d7b42984ee4c693"
+SRC_URI[sha256sum] = "5d2e7923a6e4e909df2f9fc3bf7508086ea04b0146e62015dbc93a8bf58bca74"
diff --git a/meta-efl/recipes-efl/efl/evas-generic-loaders_1.10.0.bb b/meta-efl/recipes-efl/efl/evas-generic-loaders_1.10.0.bb
deleted file mode 100644
index 732c2968ab..0000000000
--- a/meta-efl/recipes-efl/efl/evas-generic-loaders_1.10.0.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require ${BPN}.inc
-
-SRC_URI = "\
- ${E_RELEASES}/libs/${SRCNAME}/${SRCNAME}-${SRCVER}.tar.gz \
-"
-
-SRC_URI[md5sum] = "ef5ac6a7960528bb12e997f3e304f151"
-SRC_URI[sha256sum] = "f5294c1a86dd4d7d4983ec4217c0d0d1a9cfa3fc2060d4af7eec5fa4ce23a463"
diff --git a/meta-efl/recipes-efl/efl/evas-generic-loaders_1.11.0.bb b/meta-efl/recipes-efl/efl/evas-generic-loaders_1.11.0.bb
new file mode 100644
index 0000000000..0b98b11553
--- /dev/null
+++ b/meta-efl/recipes-efl/efl/evas-generic-loaders_1.11.0.bb
@@ -0,0 +1,8 @@
+require ${BPN}.inc
+
+SRC_URI = "\
+ ${E_RELEASES}/libs/${SRCNAME}/${SRCNAME}-${SRCVER}.tar.gz \
+"
+
+SRC_URI[md5sum] = "b99fd8dc1e79efacd4e212374a4f0668"
+SRC_URI[sha256sum] = "4cf55717d75214d22e6c9955bd5b2e74656cc454f011496bac74ae3df6c924e2"