aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2011-11-30 08:16:57 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-12-01 09:19:29 +0100
commit45d7250d64bf7d7c2d29d2dbf61bb6c30b683a80 (patch)
treeb5c2b0bc6e574fd322f6e2a5a0ed06cd335280d6 /meta-efl
parent4a72b57c620d2800ceac7a66e54b17235511d835 (diff)
downloadmeta-openembedded-contrib-45d7250d64bf7d7c2d29d2dbf61bb6c30b683a80.tar.gz
elementary: add gettextize patch
* normally we would call gettextize from do_configure, but efl.bbclass is running do_configure_prepend() { autopoint || touch config.rpath } before that and this respects AM_GNU_GETTEXT_VERSION which is 0.17 and later it fails with; *** error: gettext infrastructure mismatch: using a Makefile.in.in from gettext version 0.17 but the autoconf macros are from gettext version 0.18 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-efl')
-rw-r--r--meta-efl/recipes-efl/efl/elementary/0001-elementary-gettextize-0.18.1.patch76
-rw-r--r--meta-efl/recipes-efl/efl/elementary_svn.bb4
2 files changed, 79 insertions, 1 deletions
diff --git a/meta-efl/recipes-efl/efl/elementary/0001-elementary-gettextize-0.18.1.patch b/meta-efl/recipes-efl/efl/elementary/0001-elementary-gettextize-0.18.1.patch
new file mode 100644
index 0000000000..0dc16600b9
--- /dev/null
+++ b/meta-efl/recipes-efl/efl/elementary/0001-elementary-gettextize-0.18.1.patch
@@ -0,0 +1,76 @@
+From 5b81eac20242ece02f8bc42549783604a326f75d Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Thu, 17 Nov 2011 11:36:29 +0100
+Subject: [PATCH] elementary: gettextize
+
+* was complaining about wrong version
+ *** error: gettext infrastructure mismatch: using a Makefile.in.in from gettext version 0.17 but the autoconf macros are from gettext version 0.18
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ Makefile.am | 2 +-
+ configure.ac | 4 ++--
+ po/ChangeLog | 11 +++++++++++
+ 3 files changed, 14 insertions(+), 3 deletions(-)
+ delete mode 100644 ChangeLog
+
+diff --git a/ChangeLog b/ChangeLog
+deleted file mode 100644
+index e69de29..0000000
+diff --git a/Makefile.am b/Makefile.am
+index 46d2871..419a429 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -56,7 +56,7 @@ endif
+
+
+
+-EXTRA_DIST = \
++EXTRA_DIST = config.rpath \
+ README \
+ AUTHORS \
+ COPYING \
+diff --git a/configure.ac b/configure.ac
+index e5ad88c..f204693 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -631,7 +631,7 @@ EFL_ENABLE_BIN([elementary-test])
+ EFL_ENABLE_BIN([elementary-config])
+
+ m4_ifdef([AM_GNU_GETTEXT_VERSION], [
+-AM_GNU_GETTEXT_VERSION([0.17])
++AM_GNU_GETTEXT_VERSION([0.18.1])
+ ])
+
+ m4_ifdef([AM_GNU_GETTEXT], [
+@@ -657,7 +657,7 @@ EFL_CHECK_BUILD_EXAMPLES([enable_build_examples="yes"], [enable_build_examples="
+ EFL_CHECK_INSTALL_EXAMPLES([enable_install_examples="yes"], [enable_install_examples="no"])
+
+
+-AC_OUTPUT([
++AC_OUTPUT([ po/Makefile.in
+ Makefile
+ elementary.spec
+ elementary.pc
+diff --git a/po/ChangeLog b/po/ChangeLog
+index 31234d3..8ca1011 100644
+--- a/po/ChangeLog
++++ b/po/ChangeLog
+@@ -1,3 +1,14 @@
++2011-11-17 gettextize <bug-gnu-gettext@gnu.org>
++
++ * Makefile.in.in: New file, from gettext-0.18.1.
++ * Rules-quot: New file, from gettext-0.18.1.
++ * boldquot.sed: New file, from gettext-0.18.1.
++ * en@boldquot.header: New file, from gettext-0.18.1.
++ * en@quot.header: New file, from gettext-0.18.1.
++ * insert-header.sin: New file, from gettext-0.18.1.
++ * quot.sed: New file, from gettext-0.18.1.
++ * remove-potcdate.sin: New file, from gettext-0.18.1.
++
+ 2010-12-26 gettextize <bug-gnu-gettext@gnu.org>
+
+ * Makefile.in.in: New file, from gettext-0.17.
+--
+1.7.8.rc1
+
diff --git a/meta-efl/recipes-efl/efl/elementary_svn.bb b/meta-efl/recipes-efl/efl/elementary_svn.bb
index 4051caf259..840cb11e96 100644
--- a/meta-efl/recipes-efl/efl/elementary_svn.bb
+++ b/meta-efl/recipes-efl/efl/elementary_svn.bb
@@ -6,7 +6,9 @@ PV = "0.8.0+svnr${SRCPV}"
SRCREV = "${EFL_SRCREV}"
inherit efl gettext
-SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
+SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep \
+ file://0001-elementary-gettextize-0.18.1.patch \
+"
S = "${WORKDIR}/${SRCNAME}"
EXTRA_OECONF = "\