aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-07-07 08:48:07 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-07-09 15:35:10 +0200
commitce62a6e815a545ef88fd841ac7607167d6c19afe (patch)
tree56ff6935810d36658091c760bdc5f02385e78ebc /meta-efl
parent943c18cb5bc9df501ea4cb0c2bb368977b676151 (diff)
downloadmeta-openembedded-contrib-ce62a6e815a545ef88fd841ac7607167d6c19afe.tar.gz
ecore: backport patch from trunk to fix build with eglibc-2.16
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-efl')
-rw-r--r--meta-efl/recipes-efl/efl/ecore/0001-ecore_exe-fix-compilation-on-fedora-18.patch45
-rw-r--r--meta-efl/recipes-efl/efl/ecore_1.2.1.bb3
2 files changed, 47 insertions, 1 deletions
diff --git a/meta-efl/recipes-efl/efl/ecore/0001-ecore_exe-fix-compilation-on-fedora-18.patch b/meta-efl/recipes-efl/efl/ecore/0001-ecore_exe-fix-compilation-on-fedora-18.patch
new file mode 100644
index 0000000000..613cf5e478
--- /dev/null
+++ b/meta-efl/recipes-efl/efl/ecore/0001-ecore_exe-fix-compilation-on-fedora-18.patch
@@ -0,0 +1,45 @@
+From 2ad957d5da1fc91faf7c2c6562139d19f29f5b9c Mon Sep 17 00:00:00 2001
+From: caro <caro@7cbeb6ba-43b4-40fd-8cce-4c39aea84d33>
+Date: Fri, 22 Jun 2012 05:36:00 +0000
+Subject: [PATCH] ecore_exe: fix compilation on fedora 18.
+
+setpriority needs sys/resource.h. See:
+
+http://linux.die.net/man/2/setpriority
+
+I let sys/time.h, it does not hurt on linux and is anyway needed for BSD systems.
+
+
+git-svn-id: svn+ssh://svn.enlightenment.org/var/svn/e/trunk@72684 7cbeb6ba-43b4-40fd-8cce-4c39aea84d33
+---
+ src/lib/ecore/ecore_exe.c | 7 ++-----
+ 2 files changed, 6 insertions(+), 5 deletions(-)
+
+diff --git a/src/lib/ecore/ecore_exe.c b/src/lib/ecore/ecore_exe.c
+index 7931a96..6db32a9 100644
+--- a/src/lib/ecore/ecore_exe.c
++++ b/src/lib/ecore/ecore_exe.c
+@@ -2,11 +2,6 @@
+ # include <config.h>
+ #endif
+
+-#if defined (__FreeBSD__) || defined (__OpenBSD__) || defined (__NetBSD__)
+-# include <sys/time.h>
+-# include <sys/resource.h>
+-#endif
+-
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+@@ -14,6 +9,8 @@
+ #include <sys/types.h>
+ #include <unistd.h>
+ #include <fcntl.h>
++#include <sys/time.h>
++#include <sys/resource.h>
+
+ #ifdef HAVE_SYS_PRCTL_H
+ # include <sys/prctl.h>
+--
+1.7.8.6
+
diff --git a/meta-efl/recipes-efl/efl/ecore_1.2.1.bb b/meta-efl/recipes-efl/efl/ecore_1.2.1.bb
index 067042d1e1..bec47a7e68 100644
--- a/meta-efl/recipes-efl/efl/ecore_1.2.1.bb
+++ b/meta-efl/recipes-efl/efl/ecore_1.2.1.bb
@@ -1,10 +1,11 @@
require ${BPN}.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
SRC_URI = "\
${E_MIRROR}/${SRCNAME}-${PV}.tar.gz \
file://fix-ecore-fb-initialization.patch \
+ file://0001-ecore_exe-fix-compilation-on-fedora-18.patch \
"
SRC_URI[md5sum] = "557f8411d323b14ed7bf1be368ab302a"