aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-07-19 11:53:45 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2012-08-20 09:57:39 +0200
commit2a4de1a544ef16e581d41965107bc9d84cd387bb (patch)
treea8ebecd36b3565f3c70c647553861d35ecd87943 /meta-efl
parent5fd2b71ccab54b0717ebed21869754de16bd3608 (diff)
downloadmeta-openembedded-contrib-2a4de1a544ef16e581d41965107bc9d84cd387bb.tar.gz
meta-efl: unify tabs/spaces usage
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl')
-rw-r--r--meta-efl/classes/e.bbclass4
-rw-r--r--meta-efl/classes/efl.bbclass8
-rw-r--r--meta-efl/recipes-devtools/python/python-efl.inc30
-rw-r--r--meta-efl/recipes-efl/e17/e-wm-theme-illume-efenniht_svn.bb6
-rw-r--r--meta-efl/recipes-efl/e17/e-wm/applications.menu6
-rw-r--r--meta-efl/recipes-efl/e17/e-wm_svn.bb2
-rw-r--r--meta-efl/recipes-efl/e17/enjoy_svn.bb10
-rw-r--r--meta-efl/recipes-efl/e17/exalt-client_svn.bb4
-rw-r--r--meta-efl/recipes-efl/e17/exalt_svn.bb12
-rw-r--r--meta-efl/recipes-efl/e17/illume-keyboards-shr_git.bb4
-rw-r--r--meta-efl/recipes-efl/e17/news_svn.bb4
-rw-r--r--meta-efl/recipes-efl/e17/places_svn.bb2
-rw-r--r--meta-efl/recipes-efl/e17/rain_svn.bb4
-rw-r--r--meta-efl/recipes-efl/e17/screenshot_svn.bb2
-rw-r--r--meta-efl/recipes-efl/efl/ecore.inc4
-rw-r--r--meta-efl/recipes-efl/efl/edje-fpu.inc6
-rw-r--r--meta-efl/recipes-efl/efl/edje.inc14
-rw-r--r--meta-efl/recipes-efl/efl/elementary-theme-efenniht_svn.bb6
-rw-r--r--meta-efl/recipes-efl/efl/imlib2_svn.bb4
19 files changed, 66 insertions, 66 deletions
diff --git a/meta-efl/classes/e.bbclass b/meta-efl/classes/e.bbclass
index 375f914752..4bcc2bc7e1 100644
--- a/meta-efl/classes/e.bbclass
+++ b/meta-efl/classes/e.bbclass
@@ -3,12 +3,12 @@ SECTION = "e/apps"
inherit e-base autotools pkgconfig binconfig
do_prepsources () {
- make clean distclean || true
+ make clean distclean || true
}
addtask prepsources after do_patch before do_configure
do_configure_append() {
- find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
}
export CURL_CONFIG = "${STAGING_BINDIR_CROSS}/curl-config"
diff --git a/meta-efl/classes/efl.bbclass b/meta-efl/classes/efl.bbclass
index 792343b695..7cf8556746 100644
--- a/meta-efl/classes/efl.bbclass
+++ b/meta-efl/classes/efl.bbclass
@@ -10,13 +10,13 @@ inherit e-base autotools
# evas-native looks at this var, so keep it
do_configure_prepend() {
- autopoint || touch config.rpath
+ autopoint || touch config.rpath
}
do_install_prepend () {
- for i in `find ${S}/ -name "*.pc" -type f` ; do \
- sed -i -e 's:-L${STAGING_LIBDIR}:-L\$\{libdir\}:g' -e 's:-I${STAGING_LIBDIR}:-I\$\{libdir\}:g' -e 's:-I${STAGING_INCDIR}:-I\$\{includedir\}:g' $i
- done
+ for i in `find ${S}/ -name "*.pc" -type f` ; do \
+ sed -i -e 's:-L${STAGING_LIBDIR}:-L\$\{libdir\}:g' -e 's:-I${STAGING_LIBDIR}:-I\$\{libdir\}:g' -e 's:-I${STAGING_INCDIR}:-I\$\{includedir\}:g' $i
+ done
}
PACKAGES =+ "${PN}-themes"
diff --git a/meta-efl/recipes-devtools/python/python-efl.inc b/meta-efl/recipes-devtools/python/python-efl.inc
index 6ca5e3f7f4..a4df6a6952 100644
--- a/meta-efl/recipes-devtools/python/python-efl.inc
+++ b/meta-efl/recipes-devtools/python/python-efl.inc
@@ -20,24 +20,24 @@ S = "${WORKDIR}/${SRCNAME}"
do_configure_prepend() {
- # prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly
- sed -i "s#\`\$PKG_CONFIG --variable=includedir \"python-evas#${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac
+ # prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly
+ sed -i "s#\`\$PKG_CONFIG --variable=includedir \"python-evas#${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac
}
do_install_append() {
- if [ -e examples ]; then
- for i in `find examples -name "*.edc"`; do
- cd ${S}/`dirname $i`
- echo "Generating .edj file for $i..."
- edje_cc `basename $i`
- echo "Removing sources in this directory..."
- rm -f *.edc *.png *.ttf *.jpeg
- done
- cd ${S}
- install -d ${D}${datadir}/${PN}/
- cp -a examples ${D}${datadir}/${PN}/
- find ${D}${datadir}/${PN}/examples -name ".svn" | xargs rm -rf
- fi
+ if [ -e examples ]; then
+ for i in `find examples -name "*.edc"`; do
+ cd ${S}/`dirname $i`
+ echo "Generating .edj file for $i..."
+ edje_cc `basename $i`
+ echo "Removing sources in this directory..."
+ rm -f *.edc *.png *.ttf *.jpeg
+ done
+ cd ${S}
+ install -d ${D}${datadir}/${PN}/
+ cp -a examples ${D}${datadir}/${PN}/
+ find ${D}${datadir}/${PN}/examples -name ".svn" | xargs rm -rf
+ fi
}
FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*.egg/*/*/.debug"
diff --git a/meta-efl/recipes-efl/e17/e-wm-theme-illume-efenniht_svn.bb b/meta-efl/recipes-efl/e17/e-wm-theme-illume-efenniht_svn.bb
index 5ff068143d..1bf5f1de09 100644
--- a/meta-efl/recipes-efl/e17/e-wm-theme-illume-efenniht_svn.bb
+++ b/meta-efl/recipes-efl/e17/e-wm-theme-illume-efenniht_svn.bb
@@ -24,12 +24,12 @@ SRC_URI = "${E_SVN}/trunk/THEMES;module=${SRCNAME};protocol=http \
S = "${WORKDIR}/${SRCNAME}"
do_compile() {
- ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/images ${S}/efenniht.edc -o ${S}/efenniht.edj
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/images ${S}/efenniht.edc -o ${S}/efenniht.edj
}
do_install() {
- install -d ${D}${datadir}/enlightenment/data/themes/
- install -m 0644 ${S}/efenniht.edj ${D}${datadir}/enlightenment/data/themes/
+ install -d ${D}${datadir}/enlightenment/data/themes/
+ install -m 0644 ${S}/efenniht.edj ${D}${datadir}/enlightenment/data/themes/
}
FILES_${PN} = "${datadir}/enlightenment/data/themes/"
diff --git a/meta-efl/recipes-efl/e17/e-wm/applications.menu b/meta-efl/recipes-efl/e17/e-wm/applications.menu
index 77c6f0429c..ed9b906621 100644
--- a/meta-efl/recipes-efl/e17/e-wm/applications.menu
+++ b/meta-efl/recipes-efl/e17/e-wm/applications.menu
@@ -85,10 +85,10 @@
<Directory>Accessories.directory</Directory>
<Include>
<And>
- <Or>
+ <Or>
<Category>Applications</Category>
- <Category>Utility</Category>
- </Or>
+ <Category>Utility</Category>
+ </Or>
<Not>
<Category>System</Category>
<Category>Office</Category>
diff --git a/meta-efl/recipes-efl/e17/e-wm_svn.bb b/meta-efl/recipes-efl/e17/e-wm_svn.bb
index 6f5fab1410..7cc21675df 100644
--- a/meta-efl/recipes-efl/e17/e-wm_svn.bb
+++ b/meta-efl/recipes-efl/e17/e-wm_svn.bb
@@ -25,7 +25,7 @@ EXTRA_OECONF = "\
"
do_configure_prepend() {
- autopoint || true
+ autopoint || true
}
do_install_append() {
diff --git a/meta-efl/recipes-efl/e17/enjoy_svn.bb b/meta-efl/recipes-efl/e17/enjoy_svn.bb
index 81be734a73..470f03d88c 100644
--- a/meta-efl/recipes-efl/e17/enjoy_svn.bb
+++ b/meta-efl/recipes-efl/e17/enjoy_svn.bb
@@ -35,9 +35,9 @@ do_configure_prepend() {
}
pkg_postinst_${PN} () {
- echo "enjoy: SCAN and LIBRARY MANAGER are not implemeted yet!"
- echo "enjoy: Meanwhile please run:"
- echo "enjoy: test-lms -m mono -p id3 -i 5000 -s /path/to/your/music/dir /home/root/.config/enjoy/media.db"
- echo "enjoy:"
- echo "enjoy: Use test-lms -P to see available formats that can be scanned"
+ echo "enjoy: SCAN and LIBRARY MANAGER are not implemeted yet!"
+ echo "enjoy: Meanwhile please run:"
+ echo "enjoy: test-lms -m mono -p id3 -i 5000 -s /path/to/your/music/dir /home/root/.config/enjoy/media.db"
+ echo "enjoy:"
+ echo "enjoy: Use test-lms -P to see available formats that can be scanned"
}
diff --git a/meta-efl/recipes-efl/e17/exalt-client_svn.bb b/meta-efl/recipes-efl/e17/exalt-client_svn.bb
index c5219b7be2..49389006a8 100644
--- a/meta-efl/recipes-efl/e17/exalt-client_svn.bb
+++ b/meta-efl/recipes-efl/e17/exalt-client_svn.bb
@@ -8,8 +8,8 @@ DEPENDS += "elementary exalt edje-native"
CFLAGS += " -I${STAGING_INCDIR}/exalt -I${STAGING_INCDIR}/exalt_dbus"
do_configure_prepend() {
- sed -i -e /po/d configure.ac
- sed -i -e s:\ po::g Makefile.am
+ sed -i -e /po/d configure.ac
+ sed -i -e s:\ po::g Makefile.am
}
FILES_${PN} += "${libdir}/enlightenment/modules/*/*.desktop \
diff --git a/meta-efl/recipes-efl/e17/exalt_svn.bb b/meta-efl/recipes-efl/e17/exalt_svn.bb
index 3207a4ba2a..a5590e1452 100644
--- a/meta-efl/recipes-efl/e17/exalt_svn.bb
+++ b/meta-efl/recipes-efl/e17/exalt_svn.bb
@@ -19,13 +19,13 @@ EXTRA_OECONF = " \
"
do_install_append() {
- # install dbus config file
- install -d ${D}${sysconfdir}/dbus-1/system.d/
- install -m 0644 data/daemon/dbus/exalt.conf ${D}${sysconfdir}/dbus-1/system.d/exalt.conf
+ # install dbus config file
+ install -d ${D}${sysconfdir}/dbus-1/system.d/
+ install -m 0644 data/daemon/dbus/exalt.conf ${D}${sysconfdir}/dbus-1/system.d/exalt.conf
- # install dbus service file
- install -d ${D}${datadir}/dbus-1/system-services/
- install -m 0644 org.e.Exalt.service ${D}${datadir}/dbus-1/system-services/
+ # install dbus service file
+ install -d ${D}${datadir}/dbus-1/system-services/
+ install -m 0644 org.e.Exalt.service ${D}${datadir}/dbus-1/system-services/
}
FILES_${PN} += "${datadir}/dbus-1"
diff --git a/meta-efl/recipes-efl/e17/illume-keyboards-shr_git.bb b/meta-efl/recipes-efl/e17/illume-keyboards-shr_git.bb
index 36e85058d3..55f3282b7b 100644
--- a/meta-efl/recipes-efl/e17/illume-keyboards-shr_git.bb
+++ b/meta-efl/recipes-efl/e17/illume-keyboards-shr_git.bb
@@ -2,7 +2,7 @@ SECTION = "x11/data"
SRC_URI = "git://git.shr-project.org/repo/illume-keyboards.git;protocol=http;branch=master \
file://0001-Makefile-update-KEYBOARDS_DIR-for-new-illume2.patch \
- file://LICENSE"
+ file://LICENSE"
S = "${WORKDIR}/git"
SRCREV = "4064489f359a1addf572089b582f317dff5f50e1"
@@ -93,6 +93,6 @@ DESCRIPTION_illume-keyboard-persian = "Illume keyboard with persian layout"
FILES_illume-keyboard-persian = "${KEYBOARDS_DIR}/Persian.kbd ${KEYBOARDS_DIR}/Persian.png"
do_install() {
- make DESTDIR=${D} install
+ make DESTDIR=${D} install
}
diff --git a/meta-efl/recipes-efl/e17/news_svn.bb b/meta-efl/recipes-efl/e17/news_svn.bb
index 1e429e7dd1..e45cd44c05 100644
--- a/meta-efl/recipes-efl/e17/news_svn.bb
+++ b/meta-efl/recipes-efl/e17/news_svn.bb
@@ -5,8 +5,8 @@ PR = "${INC_PR}.0"
require e-module.inc
do_configure_prepend() {
- sed -i -e /po/d configure.ac
- sed -i -e s:\ po::g Makefile.am
+ sed -i -e /po/d configure.ac
+ sed -i -e s:\ po::g Makefile.am
}
diff --git a/meta-efl/recipes-efl/e17/places_svn.bb b/meta-efl/recipes-efl/e17/places_svn.bb
index 5c199332f3..6a6184be72 100644
--- a/meta-efl/recipes-efl/e17/places_svn.bb
+++ b/meta-efl/recipes-efl/e17/places_svn.bb
@@ -7,7 +7,7 @@ PR = "${INC_PR}.0"
require e-module.inc
do_configure_prepend() {
- autopoint || touch config.rpath
+ autopoint || touch config.rpath
}
# Calls /usr/bin/eject for media
diff --git a/meta-efl/recipes-efl/e17/rain_svn.bb b/meta-efl/recipes-efl/e17/rain_svn.bb
index 8738f3507d..917fe389df 100644
--- a/meta-efl/recipes-efl/e17/rain_svn.bb
+++ b/meta-efl/recipes-efl/e17/rain_svn.bb
@@ -5,8 +5,8 @@ PR = "${INC_PR}.0"
require e-module.inc
do_configure_prepend() {
- sed -i -e /po/d configure.ac
- sed -i -e s:\ po::g Makefile.am
+ sed -i -e /po/d configure.ac
+ sed -i -e s:\ po::g Makefile.am
}
diff --git a/meta-efl/recipes-efl/e17/screenshot_svn.bb b/meta-efl/recipes-efl/e17/screenshot_svn.bb
index 465ffcfea5..9689f4679a 100644
--- a/meta-efl/recipes-efl/e17/screenshot_svn.bb
+++ b/meta-efl/recipes-efl/e17/screenshot_svn.bb
@@ -10,7 +10,7 @@ DEPENDS += "emprint"
RDEPENDS_${PN} += "emprint"
do_configure_prepend() {
- sed -i -e 's:AC_MSG_ERROR(emprint not found):echo foo:g' ${S}/configure.ac
+ sed -i -e 's:AC_MSG_ERROR(emprint not found):echo foo:g' ${S}/configure.ac
}
diff --git a/meta-efl/recipes-efl/efl/ecore.inc b/meta-efl/recipes-efl/efl/ecore.inc
index bc4758acdc..e2fff0ea26 100644
--- a/meta-efl/recipes-efl/efl/ecore.inc
+++ b/meta-efl/recipes-efl/efl/ecore.inc
@@ -13,8 +13,8 @@ BBCLASSEXTEND = "native"
INC_PR = "r0"
do_configure_prepend() {
- touch ${S}/po/Makefile.in.in || true
- sed -i -e 's: po::g' ${S}/Makefile.am
+ touch ${S}/po/Makefile.in.in || true
+ sed -i -e 's: po::g' ${S}/Makefile.am
}
FILESPATHPKG =. "${BPN}-${PV}:${BPN}:"
diff --git a/meta-efl/recipes-efl/efl/edje-fpu.inc b/meta-efl/recipes-efl/efl/edje-fpu.inc
index 1af86e3cc0..dc39fa9c04 100644
--- a/meta-efl/recipes-efl/efl/edje-fpu.inc
+++ b/meta-efl/recipes-efl/efl/edje-fpu.inc
@@ -1,6 +1,6 @@
def get_edje_fpu_setting(bb, d):
- if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
- return "--enable-fixed-point"
- return ""
+ if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+ return "--enable-fixed-point"
+ return ""
diff --git a/meta-efl/recipes-efl/efl/edje.inc b/meta-efl/recipes-efl/efl/edje.inc
index 311fb52688..b3011b4d21 100644
--- a/meta-efl/recipes-efl/efl/edje.inc
+++ b/meta-efl/recipes-efl/efl/edje.inc
@@ -12,19 +12,19 @@ BBCLASSEXTEND = "native nativesdk"
INC_PR = "r0"
do_configure_prepend_virtclass-native() {
- sed -i 's:EMBRYO_PREFIX"/bin:"${STAGING_BINDIR}:' ${S}/src/bin/edje_cc_out.c
- sed -i 's: cpp -I: /usr/bin/cpp -I:' ${S}/src/bin/edje_cc_parse.c
- sed -i 's:\"gcc -I:\"/usr/bin/gcc -I:' ${S}/src/bin/edje_cc_parse.c
+ sed -i 's:EMBRYO_PREFIX"/bin:"${STAGING_BINDIR}:' ${S}/src/bin/edje_cc_out.c
+ sed -i 's: cpp -I: /usr/bin/cpp -I:' ${S}/src/bin/edje_cc_parse.c
+ sed -i 's:\"gcc -I:\"/usr/bin/gcc -I:' ${S}/src/bin/edje_cc_parse.c
}
# The new lua stuff is a bit broken...
do_configure_append() {
- for i in $(find "${S}" -name "Makefile") ; do
- sed -i -e 's:-L/usr/local/lib::g' $i
- done
+ for i in $(find "${S}" -name "Makefile") ; do
+ sed -i -e 's:-L/usr/local/lib::g' $i
+ done
}
do_compile_append() {
- sed -i -e s:local/::g -e 's:-L${STAGING_LIBDIR}::g' ${S}/edje.pc
+ sed -i -e s:local/::g -e 's:-L${STAGING_LIBDIR}::g' ${S}/edje.pc
}
# gain some extra performance at the expense of RAM - generally i'd say bad
diff --git a/meta-efl/recipes-efl/efl/elementary-theme-efenniht_svn.bb b/meta-efl/recipes-efl/efl/elementary-theme-efenniht_svn.bb
index d764e96f2a..8fb2dab043 100644
--- a/meta-efl/recipes-efl/efl/elementary-theme-efenniht_svn.bb
+++ b/meta-efl/recipes-efl/efl/elementary-theme-efenniht_svn.bb
@@ -26,12 +26,12 @@ SRC_URI += "file://LICENSE"
S = "${WORKDIR}/${SRCNAME}"
do_compile() {
- ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/images -id ${WORKDIR}/themes/ ${S}/elm-efenniht.edc -o ${S}/elm-efenniht.edj
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/images -id ${WORKDIR}/themes/ ${S}/elm-efenniht.edc -o ${S}/elm-efenniht.edj
}
do_install() {
- install -d ${D}${datadir}/elementary/themes/
- install -m 0644 ${S}/elm-efenniht.edj ${D}${datadir}/elementary/themes/
+ install -d ${D}${datadir}/elementary/themes/
+ install -m 0644 ${S}/elm-efenniht.edj ${D}${datadir}/elementary/themes/
}
FILES_${PN} = "${datadir}/elementary/themes/"
diff --git a/meta-efl/recipes-efl/efl/imlib2_svn.bb b/meta-efl/recipes-efl/efl/imlib2_svn.bb
index 83de3fedca..4cc124e10a 100644
--- a/meta-efl/recipes-efl/efl/imlib2_svn.bb
+++ b/meta-efl/recipes-efl/efl/imlib2_svn.bb
@@ -12,8 +12,8 @@ SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};protocol=http;scmdata=keep"
S = "${WORKDIR}/${SRCNAME}"
EXTRA_OECONF = "--with-x \
- --x-includes=${STAGING_INCDIR} \
- --x-libraries=${STAGING_LIBDIR} "
+ --x-includes=${STAGING_INCDIR} \
+ --x-libraries=${STAGING_LIBDIR} "
# TODO: Use more fine granular version
#OE_LT_RPATH_ALLOW=":${libdir}/imlib2/loaders:${libdir}/imlib2/filters:"