aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/efl/elementary-theme-efenniht_svn.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-03-23 18:15:03 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-03-23 18:15:03 +0100
commit7d995c58b1f3c34874110f6040021fd83d618732 (patch)
tree21db911783f88a232b3bc5a0f669b73833f63f1c /meta-efl/recipes-efl/efl/elementary-theme-efenniht_svn.bb
parent1c2cf0868bcf72847a3150416f5b48e94ba512d4 (diff)
downloadmeta-openembedded-contrib-7d995c58b1f3c34874110f6040021fd83d618732.tar.gz
meta-efl: import from meta-shr.
Not all dependencies are in yet e.g. eve is missing webkit-efl, but e-wm should build Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-efl/recipes-efl/efl/elementary-theme-efenniht_svn.bb')
-rw-r--r--meta-efl/recipes-efl/efl/elementary-theme-efenniht_svn.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/efl/elementary-theme-efenniht_svn.bb b/meta-efl/recipes-efl/efl/elementary-theme-efenniht_svn.bb
new file mode 100644
index 0000000000..79557cd6f5
--- /dev/null
+++ b/meta-efl/recipes-efl/efl/elementary-theme-efenniht_svn.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "efenniht elementary theme - Efenniht was devised to be clean and neutral. Its name (which means equinox) comes from the chromatic duality that was decided at the very beginning, with a dark theme (black and orange) and a bright one (white and blue) to be developed so that more people feel comfortable using it. Efenniht uses few animations, discrete contrasts between shades of gray and fine lines (colored) that outline the selected elements."
+SECTION = "e/utils"
+HOMEPAGE = "http://trac.enlightenment.org/e/wiki/Themes#Efenniht"
+DEPENDS = "edje-native"
+RSUGGESTS_${PN} = "e-wm-theme-illume-efenniht"
+PACKAGE_ARCH = "all"
+LICENSE = "MIT/BSD"
+
+SRCREV_THM_REV ?= "${EFL_SRCREV_1.0.0}"
+SRCREV_ELM_REV ?= "${EFL_SRCREV_1.0.0}"
+
+SRCREV_FORMAT = "THM_REV"
+PV = "0.0+svnr${SRCPV}"
+PACKAGE_ARCH = "all"
+
+inherit e-base
+
+SRCNAME = "efenniht"
+SRC_URI = "${E_SVN}/trunk/THEMES;module=${SRCNAME};proto=http;name=THM_REV"
+SRC_URI += "${E_SVN}/trunk/elementary/data;module=themes;proto=http;name=ELM_REV"
+S = "${WORKDIR}/${SRCNAME}"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/images -id ${WORKDIR}/themes/ ${S}/elm-efenniht.edc -o ${S}/elm-efenniht.edj
+}
+
+do_install() {
+ install -d ${D}${datadir}/elementary/themes/
+ install -m 0644 ${S}/elm-efenniht.edj ${D}${datadir}/elementary/themes/
+}
+
+FILES_${PN} = "${datadir}/elementary/themes/"