aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/e17/exquisite_svn.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-03-23 18:15:03 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-03-23 18:15:03 +0100
commit7d995c58b1f3c34874110f6040021fd83d618732 (patch)
tree21db911783f88a232b3bc5a0f669b73833f63f1c /meta-efl/recipes-efl/e17/exquisite_svn.bb
parent1c2cf0868bcf72847a3150416f5b48e94ba512d4 (diff)
downloadmeta-openembedded-contrib-7d995c58b1f3c34874110f6040021fd83d618732.tar.gz
meta-efl: import from meta-shr.
Not all dependencies are in yet e.g. eve is missing webkit-efl, but e-wm should build Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-efl/recipes-efl/e17/exquisite_svn.bb')
-rw-r--r--meta-efl/recipes-efl/e17/exquisite_svn.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/e17/exquisite_svn.bb b/meta-efl/recipes-efl/e17/exquisite_svn.bb
new file mode 100644
index 0000000000..fcfb65cf8f
--- /dev/null
+++ b/meta-efl/recipes-efl/e17/exquisite_svn.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "A psplash replacement for display"
+LICENSE = "MIT BSD"
+DEPENDS = "eet evas ecore embryo edje"
+PV = "0.0.1+svnr${SRCPV}"
+PR = "r11"
+SRCREV = "${EFL_SRCREV}"
+RRECOMMENDS_${PN} = "exquisite-themes"
+RCONFLICTS_${PN} = "psplash virtual-psplash"
+
+SRCNAME = "exquisite"
+
+inherit e
+SRC_URI = "${E_SVN}/trunk;module=${SRCNAME};proto=http;scmdata=keep"
+S = "${WORKDIR}/${SRCNAME}"
+
+EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
+
+SRC_URI += "file://exquisite-init"
+SRC_URI += "file://splashfuncs"
+
+inherit update-rc.d
+
+do_install_prepend() {
+ install -d ${D}/mnt/.splash/
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/exquisite-init ${D}${sysconfdir}/init.d/exquisite
+ install -d ${D}${sysconfdir}/default
+ install -m 0755 ${WORKDIR}/splashfuncs ${D}${sysconfdir}/default/splashfuncs
+ install -d ${D}${bindir}
+ ln -s exquisite-write ${D}${bindir}/splash-write
+}
+
+
+do_install_append() {
+ rm -rf ${D}${datadir}/exquisite/data/fonts/*
+}
+
+INITSCRIPT_NAME = "exquisite"
+INITSCRIPT_PARAMS = "start 01 S . stop 20 0 1 6 ."
+
+FILES_${PN} += "/mnt/.splash/"