aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-devtools
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-03-31 09:14:18 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-03-31 12:56:35 +0200
commitc5e512ae752cfef92f418c0c787c6371d3fa743c (patch)
treed2529324c68bd8e0b9e581f2b8c9b3e9db2462a3 /meta-efl/recipes-devtools
parentb6aa2bfbf6fd51ada0fb7d5f44bbafbba796a73c (diff)
downloadmeta-openembedded-contrib-c5e512ae752cfef92f418c0c787c6371d3fa743c.tar.gz
python-efl: import from meta-shr
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-devtools')
-rw-r--r--meta-efl/recipes-devtools/python/python-ecore_svn.bb6
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus_svn.bb7
-rw-r--r--meta-efl/recipes-devtools/python/python-edje/0001-fix-unicode-conversion.patch38
-rw-r--r--meta-efl/recipes-devtools/python/python-edje_svn.bb8
-rw-r--r--meta-efl/recipes-devtools/python/python-efl.inc46
-rw-r--r--meta-efl/recipes-devtools/python/python-elementary_svn.bb6
-rw-r--r--meta-efl/recipes-devtools/python/python-emotion_svn.bb6
-rw-r--r--meta-efl/recipes-devtools/python/python-evas_svn.bb5
8 files changed, 122 insertions, 0 deletions
diff --git a/meta-efl/recipes-devtools/python/python-ecore_svn.bb b/meta-efl/recipes-devtools/python/python-ecore_svn.bb
new file mode 100644
index 0000000000..0b876083ac
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-ecore_svn.bb
@@ -0,0 +1,6 @@
+require python-efl.inc
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+SRCREV = "${EFL_SRCREV}"
+DEPENDS += "python-evas ecore"
+RDEPENDS_${PN} += "python-evas"
diff --git a/meta-efl/recipes-devtools/python/python-edbus_svn.bb b/meta-efl/recipes-devtools/python/python-edbus_svn.bb
new file mode 100644
index 0000000000..d6144e9b2e
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-edbus_svn.bb
@@ -0,0 +1,7 @@
+require python-efl.inc
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+SRCREV = "${EFL_SRCREV}"
+DEPENDS += "edbus python-dbus"
+RDEPENDS_${PN} += "python-dbus"
+SRCNAME = "python-e_dbus"
diff --git a/meta-efl/recipes-devtools/python/python-edje/0001-fix-unicode-conversion.patch b/meta-efl/recipes-devtools/python/python-edje/0001-fix-unicode-conversion.patch
new file mode 100644
index 0000000000..3b0cdc627c
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-edje/0001-fix-unicode-conversion.patch
@@ -0,0 +1,38 @@
+From fa12a33b5a3c0e86231ca84967d9eff456e5f314 Mon Sep 17 00:00:00 2001
+From: Jan Luebbe <jluebbe@debian.org>
+Date: Sat, 9 Aug 2008 18:30:04 +0200
+Subject: [PATCH] fix unicode conversion
+
+---
+ edje/edje.c_edje_object.pxi | 11 +++++++----
+ 1 files changed, 7 insertions(+), 4 deletions(-)
+
+diff --git a/edje/edje.c_edje_object.pxi b/edje/edje.c_edje_object.pxi
+index 0f4da68..21c237e 100644
+--- a/edje/edje.c_edje_object.pxi
++++ b/edje/edje.c_edje_object.pxi
+@@ -415,17 +415,20 @@
+ else:
+ raise TypeError("func must be callable or None")
+
+- def part_text_set(self, char *part, char *text):
+- edje_object_part_text_set(self.obj, part, text)
++ def part_text_set(self, char *part, text):
++ cdef char *s
++ u = text.encode("utf8")
++ s = u
++ edje_object_part_text_set(self.obj, part, s)
+
+ def part_text_get(self, char *part):
+- "@rtype: str"
++ "@rtype: unicode"
+ cdef const_char_ptr s
+ s = edje_object_part_text_get(self.obj, part)
+ if s == NULL:
+ return None
+ else:
+- return s
++ return s.decode("utf8")
+
+ def part_text_select_all(self, char *part):
+ edje_object_part_text_select_all(self.obj, part)
diff --git a/meta-efl/recipes-devtools/python/python-edje_svn.bb b/meta-efl/recipes-devtools/python/python-edje_svn.bb
new file mode 100644
index 0000000000..581cc1c491
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-edje_svn.bb
@@ -0,0 +1,8 @@
+require python-efl.inc
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+SRCREV = "${EFL_SRCREV}"
+DEPENDS += "edje python-evas"
+RDEPENDS_${PN} += "python-evas"
+
+SRC_URI += "file://0001-fix-unicode-conversion.patch"
diff --git a/meta-efl/recipes-devtools/python/python-efl.inc b/meta-efl/recipes-devtools/python/python-efl.inc
new file mode 100644
index 0000000000..f816305763
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-efl.inc
@@ -0,0 +1,46 @@
+DESCRIPTION = "${PN} bindings"
+LICENSE = "BSD"
+AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>"
+# NOTE: Due to a bug in distutils, even if we don't use pyrex but cython,
+# we need to build pyrex otherwise cython doesn't get called to build
+# the extension modules.
+DEPENDS = "python-cython-native python-pyrex-native python-numeric eina"
+RDEPENDS_${PN} += "python-lang"
+PV = "0.7.3+svnr${SRCPV}"
+PR = "ml1"
+
+# necessary to let the call for python-config succeed
+export BUILD_SYS
+export HOST_SYS
+
+inherit e-base autotools pkgconfig distutils-base
+
+SRC_URI = "${E_SVN}/trunk/BINDINGS/python;module=${SRCNAME};proto=http"
+S = "${WORKDIR}/${SRCNAME}"
+
+
+do_configure_prepend() {
+ # prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly
+ sed -i "s#\`\$PKG_CONFIG --variable=includedir \"python-evas#${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac
+}
+
+do_install_append() {
+ if [ -e examples ]; then
+ for i in `find examples -name "*.edc"`; do
+ cd ${S}/`dirname $i`
+ echo "Generating .edj file for $i..."
+ edje_cc `basename $i`
+ echo "Removing sources in this directory..."
+ rm -f *.edc *.png *.ttf *.jpeg
+ done
+ cd ${S}
+ install -d ${D}${datadir}/${PN}/
+ cp -a examples ${D}${datadir}/${PN}/
+ find ${D}${datadir}/${PN}/examples -name ".svn" | xargs rm -rf
+ fi
+}
+
+FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*.egg/*/*/.debug"
+
+PACKAGES += "${PN}-examples"
+FILES_${PN}-examples = "${datadir}/${PN}/examples"
diff --git a/meta-efl/recipes-devtools/python/python-elementary_svn.bb b/meta-efl/recipes-devtools/python/python-elementary_svn.bb
new file mode 100644
index 0000000000..e7f18ecfb6
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-elementary_svn.bb
@@ -0,0 +1,6 @@
+require python-efl.inc
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=6a6a8e020838b23406c81b19c1d46df6"
+SRCREV = "${EFL_SRCREV}"
+DEPENDS += "elementary python-evas"
+RDEPENDS_${PN} += "python-evas python-ecore python-edje"
diff --git a/meta-efl/recipes-devtools/python/python-emotion_svn.bb b/meta-efl/recipes-devtools/python/python-emotion_svn.bb
new file mode 100644
index 0000000000..ae2eb4c66f
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-emotion_svn.bb
@@ -0,0 +1,6 @@
+require python-efl.inc
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+SRCREV = "${EFL_SRCREV}"
+DEPENDS += "emotion python-evas"
+RDEPENDS_${PN} += "python-ecore"
diff --git a/meta-efl/recipes-devtools/python/python-evas_svn.bb b/meta-efl/recipes-devtools/python/python-evas_svn.bb
new file mode 100644
index 0000000000..8ec9c41dc8
--- /dev/null
+++ b/meta-efl/recipes-devtools/python/python-evas_svn.bb
@@ -0,0 +1,5 @@
+require python-efl.inc
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+SRCREV = "${EFL_SRCREV}"
+DEPENDS += "evas"