aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-devtools/python/python-edbus.inc
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-01-31 21:11:52 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-02-23 23:21:14 +0100
commit9234bcb0d30e66db7b8fcfd867086185649ecbae (patch)
treefaddf5d0a24254d5e6121f92aa83b901c14ff450 /meta-efl/recipes-devtools/python/python-edbus.inc
parent29a37034c1205cd468815be33c69dcb560e77b67 (diff)
downloadmeta-openembedded-contrib-9234bcb0d30e66db7b8fcfd867086185649ecbae.tar.gz
python-efl: upgrade from separate recipes to shared python-efl-1.8.1
* python-ecore, python-edbus, python-edje, python-elementary, python-emotion, python-evas are now built from single source tree * announcements: 1.8.0: http://sourceforge.net/mailarchive/message.php?msg_id=31728838 1.8.1: http://sourceforge.net/mailarchive/message.php?msg_id=31862842 * be aware that upgrade-path wont probably work correctly and that you have to manually cleanup your sysroots before migrating to new shared efl recipe, for details see https://bugzilla.yoctoproject.org/show_bug.cgi?id=4102 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-efl/recipes-devtools/python/python-edbus.inc')
-rw-r--r--meta-efl/recipes-devtools/python/python-edbus.inc50
1 files changed, 47 insertions, 3 deletions
diff --git a/meta-efl/recipes-devtools/python/python-edbus.inc b/meta-efl/recipes-devtools/python/python-edbus.inc
index 86ae773436..1d8098f60d 100644
--- a/meta-efl/recipes-devtools/python/python-edbus.inc
+++ b/meta-efl/recipes-devtools/python/python-edbus.inc
@@ -1,6 +1,50 @@
-require python-efl.inc
+DESCRIPTION = "${PN} bindings"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
-DEPENDS += "edbus python-dbus"
-RDEPENDS_${PN} += "python-dbus"
+AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>"
+# NOTE: Due to a bug in distutils, even if we don't use pyrex but cython,
+# we need to build pyrex otherwise cython doesn't get called to build
+# the extension modules.
+DEPENDS = "python-cython-native python-pyrex-native python-numeric eina edbus python-dbus"
+RDEPENDS_${PN} += "python-lang python-dbus"
+
+# necessary to let the call for python-config succeed
+export BUILD_SYS
+export HOST_SYS
+
+inherit e-base autotools pkgconfig distutils-base
+
SRCNAME = "python-e_dbus"
+SRCVER = "${PV}"
+
+SRC_URI = "\
+ ${E_MIRROR}/BINDINGS/python/${SRCNAME}-${SRCVER}.tar.bz2 \
+"
+S = "${WORKDIR}/${SRCNAME}-${SRCVER}"
+
+
+do_configure_prepend() {
+ # prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly
+ sed -i "s#=\`\$PKG_CONFIG --variable=includedir \"python-evas#=${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac
+}
+
+do_install_append() {
+ if [ -e examples ]; then
+ for i in `find examples -name "*.edc"`; do
+ cd ${S}/`dirname $i`
+ echo "Generating .edj file for $i..."
+ edje_cc `basename $i`
+ echo "Removing sources in this directory..."
+ rm -f *.edc *.png *.ttf *.jpeg
+ done
+ cd ${S}
+ install -d ${D}${datadir}/${PN}/
+ cp -a examples ${D}${datadir}/${PN}/
+ find ${D}${datadir}/${PN}/examples -name ".svn" | xargs rm -rf
+ fi
+}
+
+FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*.egg/*/*/.debug"
+
+PACKAGES += "${PN}-examples"
+FILES_${PN}-examples = "${datadir}/${PN}/examples"