aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOvidiu Panait <ovidiu.panait@windriver.com>2018-07-16 20:12:50 +0300
committerKhem Raj <raj.khem@gmail.com>2018-07-16 18:42:41 -0700
commitd3cbf507240f7c3604dcc10df71f1fdf40e6851e (patch)
tree736a7c4521564aea55da38e3219d3b72645b4d89
parent5cf053a7f53333ec72a991351d2efabba75bdc9a (diff)
downloadmeta-openembedded-contrib-d3cbf507240f7c3604dcc10df71f1fdf40e6851e.tar.gz
nativesdk-lvm2: Fix installed-vs-shipped errors
Fix the following build errors: $ bitbake nativesdk-lvm2 ERROR: nativesdk-lvm2-2.02.177-r0 do_package: QA Issue: nativesdk-lvm2: Files/directories were installed but not shipped in any package: /etc /etc/lvm /etc/lvm/lvmlocal.conf /etc/lvm/lvm.conf /etc/lvm/profile /etc/lvm/profile/metadata_profile_template.profile /etc/lvm/profile/cache-smq.profile /etc/lvm/profile/thin-generic.profile /etc/lvm/profile/command_profile_template.profile /etc/lvm/profile/cache-mq.profile /etc/lvm/profile/thin-performance.profile /etc/lvm/profile/lvmdbusd.profile ... nativesdk-lvm2: 12 installed and not shipped files. [installed-vs-shipped] Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2_2.02.177.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/lvm2/lvm2_2.02.177.bb b/meta-oe/recipes-support/lvm2/lvm2_2.02.177.bb
index 390970fcb2..1d9de3d944 100644
--- a/meta-oe/recipes-support/lvm2/lvm2_2.02.177.bb
+++ b/meta-oe/recipes-support/lvm2/lvm2_2.02.177.bb
@@ -34,6 +34,8 @@ SYSTEMD_AUTO_ENABLE = "disable"
TARGET_CC_ARCH += "${LDFLAGS}"
+EXTRA_OECONF_append_class-nativesdk = " --with-confdir=${sysconfdir}"
+
FILES_${PN} += "${libdir}/device-mapper/*.so"
FILES_${PN}-scripts = " \
${sbindir}/blkdeactivate \
@@ -45,6 +47,7 @@ FILES_${PN}-scripts = " \
# up automatically:
FILES_${PN}-udevrules = "${nonarch_base_libdir}/udev/rules.d"
RDEPENDS_${PN}_append_class-target = " libdevmapper"
+RDEPENDS_${PN}_append_class-nativesdk = " libdevmapper"
RDEPENDS_${PN}-scripts = "${PN} (= ${EXTENDPKGV}) bash"
RRECOMMENDS_${PN}_class-target = "${PN}-scripts (= ${EXTENDPKGV})"