aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2014-12-18 13:12:16 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-12-19 20:10:58 +0100
commit6d3437c768db67e3d40aa8f97497f3024acc97ee (patch)
treee3cb0ef05d91b9e1b8096e50e96701375ecf5c79
parent6b2c49e581330998b1f9a0a7181f38912b06288e (diff)
downloadmeta-openembedded-contrib-6d3437c768db67e3d40aa8f97497f3024acc97ee.tar.gz
python-pep8: import from meta-openstack
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-pep8_1.4.6.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pep8_1.4.6.bb b/meta-python/recipes-devtools/python/python-pep8_1.4.6.bb
new file mode 100644
index 0000000000..b3c743ebd7
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pep8_1.4.6.bb
@@ -0,0 +1,23 @@
+# Imported from git://git.yoctoproject.org/meta-cloud-services
+
+SUMMARY = "Python style guide checker"
+HOMEPAGE = "https://github.com/dreamhost/cliff"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://README.rst;md5=b0d37793ab91ca25ad5c200e9ea22331"
+
+SRCNAME = "pep8"
+
+SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "a03bb494859e87b42601b61b1b043a0c"
+SRC_URI[sha256sum] = "603a46e5c358ce20ac4807a0eeafac7505d1125a4c1bd8378757ada06f61bed8"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} += " \
+ python-prettytable \
+ python-cmd2 \
+ python-pyparsing"