aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-11-19 23:57:29 -0800
committerRobert Yang <liezhi.yang@windriver.com>2015-11-20 01:35:50 -0800
commit6293f10f15c02a4c68cbb8ce39ccc6f495517ac7 (patch)
treee80f3d91f98391c7a0a4bea325e8906b7bac71b7
parente5a41eb40fd626200107e9f8902fd0250e4022ad (diff)
downloadmeta-openembedded-contrib-6293f10f15c02a4c68cbb8ce39ccc6f495517ac7.tar.gz
cim-schema-exper: fix host-user-contaminated
Fixed: cim-schema-exper-2.39.0: cim-schema-exper: /cim-schema-exper/usr/share/mof/cimv2.39.0/Network/CIM_IPAddressRange.mof is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] cim-schema-final-2.40.0: cim-schema-final: /cim-schema-final/usr/share/mof/cimv2.40.0/Network/CIM_IPAddressRange.mof is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] lib32-cim-schema-exper-2.39.0: lib32-cim-schema-exper: /lib32-cim-schema-exper/usr/share/mof/cimv2.39.0/Network/CIM_IPAddressRange.mof is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] lib32-cim-schema-final-2.40.0: lib32-cim-schema-final: /lib32-cim-schema-final/usr/share/mof/cimv2.40.0/Network/CIM_IPAddressRange.mof is owned by uid 15220, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] It uses cp -a to install the files, so fix the owner to root:root Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb1
-rw-r--r--meta-networking/recipes-support/cim-schema/cim-schema-final_2.40.0.bb1
2 files changed, 2 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb b/meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb
index 62e50df1d3..e4ed7b3628 100644
--- a/meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb
+++ b/meta-networking/recipes-support/cim-schema/cim-schema-exper_2.39.0.bb
@@ -17,6 +17,7 @@ do_install() {
install -m 644 ${WORKDIR}/LICENSE ${D}${datadir}/doc/cim-schema-${PV}
cp -a ${S}/* ${D}${datadir}/mof/cimv${PV}/
+ chown -R root:root ${D}${datadir}/mof/cimv${PV}
for i in `find ${D}${datadir}/mof/cimv${PV} -name "*.mof"`; do
sed -i -e 's/\r//g' $i
done
diff --git a/meta-networking/recipes-support/cim-schema/cim-schema-final_2.40.0.bb b/meta-networking/recipes-support/cim-schema/cim-schema-final_2.40.0.bb
index 1694f31824..7ab9c4d492 100644
--- a/meta-networking/recipes-support/cim-schema/cim-schema-final_2.40.0.bb
+++ b/meta-networking/recipes-support/cim-schema/cim-schema-final_2.40.0.bb
@@ -22,6 +22,7 @@ do_install() {
install -m 644 ${WORKDIR}/LICENSE ${D}${datadir}/doc/cim-schema-${PV}
cp -a ${S}/* ${D}${datadir}/mof/cimv${PV}/
+ chown -R root:root ${D}${datadir}/mof/cimv${PV}/
for i in `find ${D}${datadir}/mof/cimv${PV} -name "*.mof"`; do
sed -i -e 's/\r//g' $i
done