aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorQi.Chen@windriver.com <Qi.Chen@windriver.com>2016-12-28 15:46:40 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-13 18:40:13 +0100
commit300d2303049f80f1c20160282e637b76ec7f6548 (patch)
treef02c764425f3c81be8e1f844709cf19645072b72
parente5d586750e05878683926d039c9e66ca33505386 (diff)
downloadmeta-openembedded-contrib-300d2303049f80f1c20160282e637b76ec7f6548.tar.gz
rsyslog: use atomic builtins to avoid race issue
rsyslog uses a small program to check if compiler has atomic builtins or not. This does not work when cross compiling, resulting in potential race issue. In fact, when running ptest on intel-x86-64 board, we have met the race problem. As our compiler gcc, has atomic builtins, we force ap_cv_atomic_builtins to be 'yes' so that rsyslog could make use of the atomic builtins and avoid the race issue. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta-oe/recipes-extended/rsyslog/rsyslog_8.22.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/rsyslog/rsyslog_8.22.0.bb b/meta-oe/recipes-extended/rsyslog/rsyslog_8.22.0.bb
index c0e0a6d69c..62126f8fb5 100644
--- a/meta-oe/recipes-extended/rsyslog/rsyslog_8.22.0.bb
+++ b/meta-oe/recipes-extended/rsyslog/rsyslog_8.22.0.bb
@@ -31,7 +31,7 @@ SRC_URI[sha256sum] = "06e2884181333dccecceaca82827ae24ca7a258b4fbf7b1e07a80d4caa
inherit autotools pkgconfig systemd update-rc.d ptest
-EXTRA_OECONF += "--disable-generate-man-pages"
+EXTRA_OECONF += "--disable-generate-man-pages ap_cv_atomic_builtins=yes"
# first line is default yes in configure
PACKAGECONFIG ??= " \