aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan McGregor <dan.mcgregor@usask.ca>2015-11-04 23:05:54 -0600
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-06 17:53:57 +0100
commit0b895ac766b3e5843a38cc7838368eed53386ab3 (patch)
treee747b8ae41bfa88ff3b101193fdd3c6912def148
parent2528b25bb5310df4dddde4394db3cb56760c1616 (diff)
downloadmeta-openembedded-contrib-0b895ac766b3e5843a38cc7838368eed53386ab3.tar.gz
python-html5lib: import recipe from meta-openstack
This recipe is needed for GateOne. Signed-off-by: Dan McGregor <dan.mcgregor@usask.ca> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-html5lib_0.999.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-html5lib_0.999.bb b/meta-python/recipes-devtools/python/python-html5lib_0.999.bb
new file mode 100644
index 0000000000..34a8b30593
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-html5lib_0.999.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "HTML parser based on the WHATWG HTML specifcation"
+HOMEPAGE = "https://github.com/html5lib/html5lib-python"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1ba5ada9e6fead1fdc32f43c9f10ba7c"
+
+SRCNAME = "html5lib"
+SRC_URI = "http://pypi.python.org/packages/source/h/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "acb8ba4d6db5637360a07859192eb7f8"
+SRC_URI[sha256sum] = "c3887f7e2875d7666107fa8bee761ff95b9391acdcc7cd1b5fd57a23b5fbc49e"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools