aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Barker <paul@paulbarker.me.uk>2014-05-28 22:10:40 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2014-06-10 12:27:20 +0200
commit05620be79aebb2608044891c5fbaef2659c77986 (patch)
tree945bf1cabd145331dc0975e971f14b060040c31c
parent20459d1760b6af2097a9d6cef1bf9338ba70c3c9 (diff)
downloadmeta-openembedded-contrib-05620be79aebb2608044891c5fbaef2659c77986.tar.gz
vim: Fix packaging of common data files
The majority of the vim runtime files have been moved from the package 'vim-data' to the package 'vim-common'. However, 'vim-data' was still in RRECOMMENDS and 'vim-common' was not, so the runtime files were not being installed by default. To fix this, 'vim-data' is removed from RRECOMMENDS and 'vim-common' is added instead. 'vim-data' is also removed from PACKAGES as it should now be empty. Signed-off-by: Paul Barker <paul@paulbarker.me.uk> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/vim/vim_7.4.258.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/vim/vim_7.4.258.bb b/meta-oe/recipes-support/vim/vim_7.4.258.bb
index 2d3b0c26ab..cfc82b1650 100644
--- a/meta-oe/recipes-support/vim/vim_7.4.258.bb
+++ b/meta-oe/recipes-support/vim/vim_7.4.258.bb
@@ -70,7 +70,7 @@ do_install_append() {
PARALLEL_MAKEINST = ""
-PACKAGES =+ "${PN}-common ${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-data"
+PACKAGES =+ "${PN}-common ${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc"
FILES_${PN}-syntax = "${datadir}/${PN}/${VIMDIR}/syntax"
FILES_${PN}-help = "${datadir}/${PN}/${VIMDIR}/doc"
FILES_${PN}-tutor = "${datadir}/${PN}/${VIMDIR}/tutor ${bindir}/${PN}tutor"
@@ -93,7 +93,7 @@ FILES_${PN}-common = " \
"
# Recommend that runtime data is installed along with vim
-RRECOMMENDS_${PN} = "${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-data"
+RRECOMMENDS_${PN} = "${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-common"
ALTERNATIVE_${PN} = "vi"
ALTERNATIVE_TARGET[vi] = "${bindir}/${PN}"