aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Miartus <adam.miartus@softhows.eu>2021-02-26 20:11:40 +0100
committerKhem Raj <raj.khem@gmail.com>2021-02-26 15:22:35 -0800
commitbca96e33845f39fe78f3ae7fbe25b0a09c62c993 (patch)
tree3544192650d09d59f54c72481ccd5cb393250270
parent40237897d9aa4956e5a546c8629abfa022ba61c8 (diff)
downloadmeta-openembedded-contrib-bca96e33845f39fe78f3ae7fbe25b0a09c62c993.tar.gz
libcereal: add dev package that can be included into toolchain sdk
Signed-off-by: Adam Miartus <adam.miartus@softhows.eu> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/libcereal/libcereal_1.3.0.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libcereal/libcereal_1.3.0.bb b/meta-oe/recipes-support/libcereal/libcereal_1.3.0.bb
index 2f8978c9d0..55fb3ebcfc 100644
--- a/meta-oe/recipes-support/libcereal/libcereal_1.3.0.bb
+++ b/meta-oe/recipes-support/libcereal/libcereal_1.3.0.bb
@@ -17,10 +17,19 @@ SRC_URI = "git://github.com/USCiLab/cereal.git"
S = "${WORKDIR}/git"
-inherit cmake
+inherit cmake pkgconfig
EXTRA_OECMAKE = "-DJUST_INSTALL_CEREAL=ON"
ALLOW_EMPTY_${PN} = "1"
+RDEPENDS_${PN}-dev = ""
+
+PROVIDES += "${PN}-dev"
+
+FILES_${PN}-dev = " \
+ ${includedir} \
+ ${libdir} \
+"
+
BBCLASSEXTEND = "native nativesdk"