aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-02-23 11:06:46 -0800
committerKhem Raj <raj.khem@gmail.com>2021-02-23 11:08:21 -0800
commit8c1c0ad349d59b6d5a94a1eea91068d98e19f6f7 (patch)
tree96493627a274a540fa8a3cfcaedba77a9487a9ba
parent367685ac887d6dff47ef7d6b833f109d13d9384c (diff)
downloadmeta-openembedded-contrib-8c1c0ad349d59b6d5a94a1eea91068d98e19f6f7.tar.gz
nss: Add powerpc64 little endian support
Fix build with clang/ppc64le while here Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/nss/nss_3.60.1.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/nss/nss_3.60.1.bb b/meta-oe/recipes-support/nss/nss_3.60.1.bb
index dc147efea4..25a2bc2513 100644
--- a/meta-oe/recipes-support/nss/nss_3.60.1.bb
+++ b/meta-oe/recipes-support/nss/nss_3.60.1.bb
@@ -52,6 +52,14 @@ do_configure_prepend_libc-musl () {
sed -i -e '/-DHAVE_SYS_CDEFS_H/d' ${S}/nss/lib/dbm/config/config.mk
}
+do_configure_prepend_powerpc64le_toolchain-clang () {
+ sed -i -e 's/\-std=c99/\-std=gnu99/g' ${S}/nss/coreconf/command.mk
+}
+
+do_configure_prepend_powerpc64_toolchain-clang () {
+ sed -i -e 's/\-std=c99/\-std=gnu99/g' ${S}/nss/coreconf/command.mk
+}
+
do_compile_prepend_class-native() {
export NSPR_INCLUDE_DIR=${STAGING_INCDIR_NATIVE}/nspr
export NSPR_LIB_DIR=${STAGING_LIBDIR_NATIVE}
@@ -93,7 +101,7 @@ do_compile() {
if [ "${TARGET_ARCH}" = "powerpc" ]; then
OS_TEST=ppc
- elif [ "${TARGET_ARCH}" = "powerpc64" ]; then
+ elif [ "${TARGET_ARCH}" = "powerpc64" -o "${TARGET_ARCH}" = "powerpc64le" ]; then
OS_TEST=ppc64
elif [ "${TARGET_ARCH}" = "mips" -o "${TARGET_ARCH}" = "mipsel" -o "${TARGET_ARCH}" = "mips64" -o "${TARGET_ARCH}" = "mips64el" ]; then
OS_TEST=mips
@@ -151,7 +159,7 @@ do_install() {
if [ "${TARGET_ARCH}" = "powerpc" ]; then
OS_TEST=ppc
- elif [ "${TARGET_ARCH}" = "powerpc64" ]; then
+ elif [ "${TARGET_ARCH}" = "powerpc64" -o "${TARGET_ARCH}" = "powerpc64le" ]; then
OS_TEST=ppc64
elif [ "${TARGET_ARCH}" = "mips" -o "${TARGET_ARCH}" = "mipsel" -o "${TARGET_ARCH}" = "mips64" -o "${TARGET_ARCH}" = "mips64el" ]; then
OS_TEST=mips