aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-03-03 08:12:41 -0800
committerKhem Raj <raj.khem@gmail.com>2023-03-04 08:45:47 -0800
commit7da9aaa9209b66bc6da65f7e4a3520f400bb4701 (patch)
tree420d10cbefa12f7888198fccbde89c74b580f8e7
parent15aa347b438214be0c223ff507a507864ce4990f (diff)
downloadmeta-openembedded-contrib-7da9aaa9209b66bc6da65f7e4a3520f400bb4701.tar.gz
glog: Disable 64bit atomics on rv32
Fixes riscv32-yoe-linux-ld: CMakeFiles/logging_unittest.dir/src/logging_unittest.cc.o: in function `no symbol': /usr/include/c++/v1/vector:835: undefined reference to `__atomic_load_8' Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/glog/glog_0.6.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/glog/glog_0.6.0.bb b/meta-oe/recipes-support/glog/glog_0.6.0.bb
index 89b7cfd184..5d12ba6931 100644
--- a/meta-oe/recipes-support/glog/glog_0.6.0.bb
+++ b/meta-oe/recipes-support/glog/glog_0.6.0.bb
@@ -20,7 +20,7 @@ inherit cmake
PACKAGECONFIG ?= "shared unwind 64bit-atomics"
PACKAGECONFIG:remove:riscv64 = "unwind"
-PACKAGECONFIG:remove:riscv32 = "unwind"
+PACKAGECONFIG:remove:riscv32 = "unwind 64bit-atomics"
PACKAGECONFIG:remove:mipsarch = "64bit-atomics"
PACKAGECONFIG:append:libc-musl:riscv64 = " execinfo"