aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-20 10:16:02 -0700
committerKhem Raj <raj.khem@gmail.com>2021-10-20 12:33:31 -0700
commit7d911e6d6b1db30dfb247d24678333e52f2ea974 (patch)
tree11f48d9b8ef43ee0024901c878faf1201224d6c8
parent833e0598552444bed850969077dc78e41205a286 (diff)
downloadmeta-openembedded-contrib-7d911e6d6b1db30dfb247d24678333e52f2ea974.tar.gz
bluepy: Set PV and correct syntax for RDEPENDS
Also organize the recipe to to match OE style Remove PYTHON_PN from DEPENDS, setuptools should be enough Correct setting LIC_FILES_CHKSUM Move setting git SHA to SRCREV Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Marco Cavallini <m.cavallini@koansoftware.com> Cc: Martin Jansa <martin.jansa@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/bluepy/bluepy_git.bb15
1 files changed, 8 insertions, 7 deletions
diff --git a/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb b/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb
index 03b1562b60..bc1893eb08 100644
--- a/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb
+++ b/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb
@@ -1,17 +1,18 @@
DESCRIPTION = "Python interface to Bluetooth LE on Linux"
HOMEPAGE = "https://github.com/IanHarvey/bluepy"
SECTION = "devel/python"
+LICENSE = "GPLv2 & PD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=59e0d45ea684dda215889aa1b5acd001"
+DEPENDS = "glib-2.0"
+SRCREV = "7ad565231a97c304c0eff45f2649cd005e69db09"
+PV = "1.3.0+git${SRCPV}"
-DEPENDS = "${PYTHON_PN} glib-2.0"
-RDEPENDS_${PN} = "bluez5"
+SRC_URI = "git://github.com/IanHarvey/bluepy.git;protocol=https"
-LICENSE = "GPLv2 & PD"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/PD;md5=b3597d12946881e13cb3b548d1173851"
+S = "${WORKDIR}/git"
inherit setuptools3 pkgconfig
-SRC_URI = "git://github.com/IanHarvey/bluepy.git;protocol=https;rev=7ad565231a97c304c0eff45f2649cd005e69db09"
-S = "${WORKDIR}/git"
+RDEPENDS:${PN} = "bluez5"
TARGET_CC_ARCH += "${LDFLAGS}"