aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorakuster <akuster808@gmail.com>2021-02-17 20:29:33 +0000
committerKhem Raj <raj.khem@gmail.com>2021-02-17 14:01:51 -0800
commit7b7a8412a41ba96cc19ee330c764753fdb04ceb8 (patch)
tree97c023082c9763b4230d7b4a1986bdf354bd328e
parentac4c2dc26d935d89fa7de498ddbb1f8dee7b3718 (diff)
downloadmeta-openembedded-contrib-7b7a8412a41ba96cc19ee330c764753fdb04ceb8.tar.gz
softhsm: update to 2.6.1 and align
meta-security has this pkg to but newer. Move from meta-sec to meta-oe minor cleanups. Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-security/softhsm/softhsm_2.6.1.bb30
-rw-r--r--meta-oe/recipes-security/softhsm/softhsm_git.bb18
2 files changed, 30 insertions, 18 deletions
diff --git a/meta-oe/recipes-security/softhsm/softhsm_2.6.1.bb b/meta-oe/recipes-security/softhsm/softhsm_2.6.1.bb
new file mode 100644
index 0000000000..aa91ab37f2
--- /dev/null
+++ b/meta-oe/recipes-security/softhsm/softhsm_2.6.1.bb
@@ -0,0 +1,30 @@
+SUMMARY = "PKCS#11 HSM/Token Emulator"
+HOMEPAGE = "https://www.opendnssec.org/softhsm/"
+LICENSE = "BSD-2-Clause & ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ef3f77a3507c3d91e75b9f2bdaee4210"
+
+DEPENDS = "sqlite3"
+
+SRC_URI = "https://dist.opendnssec.org/source/softhsm-2.6.1.tar.gz"
+SRC_URI[sha256sum] = "61249473054bcd1811519ef9a989a880a7bdcc36d317c9c25457fc614df475f2"
+
+inherit autotools pkgconfig siteinfo
+
+EXTRA_OECONF += " --with-sqlite3=${STAGING_DIR_HOST}/usr"
+EXTRA_OECONF += "${@oe.utils.conditional('SITEINFO_BITS', '64', ' --enable-64bit', '', d)}"
+
+PACKAGECONFIG ?= "ecc eddsa pk11 openssl"
+
+PACKAGECONFIG[npm] = ",--disable-non-paged-memory"
+PACKAGECONFIG[ecc] = "--enable-ecc,--disable-ecc"
+PACKAGECONFIG[gost] = "--enable-gost,--disable-gost"
+PACKAGECONFIG[eddsa] = "--enable-eddsa, --disable-eddsa"
+PACKAGECONFIG[fips] = "--enable-fips, --disable-fips"
+PACKAGECONFIG[notvisable] = "--disable-visibility"
+PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}/usr --with-crypto-backend=openssl, --without-openssl, openssl, openssl"
+PACKAGECONFIG[botan] = "--with-botan=${STAGING_DIR_HOST}/usr --with-crypto-backend=botan, --without-botan, botan"
+PACKAGECONFIG[migrate] = "--with-migrate"
+PACKAGECONFIG[pk11] = "--enable-p11-kit --with-p11-kit==${STAGING_DIR_HOST}/usr, --without-p11-kit, p11-kit, p11-kit"
+
+RDEPENDS_${PN} = "sqlite3"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-security/softhsm/softhsm_git.bb b/meta-oe/recipes-security/softhsm/softhsm_git.bb
deleted file mode 100644
index 3236cb9a60..0000000000
--- a/meta-oe/recipes-security/softhsm/softhsm_git.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-SUMMARY = "PKCS#11 HSM/Token Emulator"
-HOMEPAGE = "https://www.opendnssec.org/softhsm/"
-LICENSE = "BSD-2-Clause & ISC"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=ef3f77a3507c3d91e75b9f2bdaee4210"
-DEPENDS = "openssl"
-PV = "2.5.0"
-
-SRC_URI = "git://github.com/opendnssec/SoftHSMv2.git;branch=master"
-SRCREV = "369df0383d101bc8952692c2a368ac8bc887d1b4"
-
-S = "${WORKDIR}/git"
-
-inherit autotools pkgconfig
-
-# EdDSA requires OpenSSL >= 1.1.1
-EXTRA_OECONF = "--enable-eddsa --disable-gost"
-
-BBCLASSEXTEND = "native"