aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnatol Belski <anbelski@linux.microsoft.com>2021-02-19 12:58:45 +0000
committerKhem Raj <raj.khem@gmail.com>2021-02-20 10:40:53 -0800
commit7223513f400d63d1fb50d65b123d00ceb94f3695 (patch)
treea04c90084bf8350cdae66e650f6ed2d249708c6d
parent8d07411a9ebe7eba2a25b5db60d26ae0cdf1d4de (diff)
downloadmeta-openembedded-contrib-7223513f400d63d1fb50d65b123d00ceb94f3695.tar.gz
abseil-cpp: Relax build requirements
While better hardware acceleration is definitely advantageous, there is no hard requirement defined by the upstream. Removing this will allow builds targeting older hardware where DEFAULTTUNE can't be changed. If found useful, this can also be backported to lower branches. Signed-off-by: Anatol Belski <anbelski@linux.microsoft.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb24
1 files changed, 0 insertions, 24 deletions
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
index cc7bf01d73..7d935d523b 100644
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
+++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
@@ -34,27 +34,3 @@ ALLOW_EMPTY_${PN} = "1"
FILES_${PN} = "${libdir}/libabsl_*.so ${libdir}/cmake"
FILES_${PN}-dev = "${includedir}"
-python () {
- arch = d.getVar("TARGET_ARCH")
-
- if arch == "aarch64":
- tunes = d.getVar("TUNE_FEATURES")
- if not tunes:
- raise bb.parse.SkipRecipe("%s-%s Needs support for crypto on armv8" % (pkgn, pkgv))
- return
- pkgn = d.getVar("PN")
- pkgv = d.getVar("PV")
- if "crypto" not in tunes:
- raise bb.parse.SkipRecipe("%s-%s Needs support for crypto on armv8" % (pkgn, pkgv))
-
- if arch == "x86_64":
- tunes = d.getVar("TUNE_FEATURES")
- if not tunes:
- raise bb.parse.SkipRecipe("%s-%s Needs support for corei7 on x86_64" % (pkgn, pkgv))
- return
- pkgn = d.getVar("PN")
- pkgv = d.getVar("PV")
- if "corei7" not in tunes:
- raise bb.parse.SkipRecipe("%s-%s Needs support for corei7 on x86_64" % (pkgn, pkgv))
-
-}