aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-20 14:04:12 -0700
committerKhem Raj <raj.khem@gmail.com>2021-10-20 15:14:04 -0700
commit5fd3937da1e55a3afc40a38ced9fef57c394fae1 (patch)
tree84375d81dce7043c25975bb845eab27e3f2d6666
parentfc282987d2ea1695d53017397bb8771f3303c2ff (diff)
downloadmeta-openembedded-contrib-5fd3937da1e55a3afc40a38ced9fef57c394fae1.tar.gz
bluepy: Fix permissions on tarball
Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Marco Cavallini <m.cavallini@koansoftware.com>
-rw-r--r--meta-networking/recipes-connectivity/bluepy/bluepy/0001-bluepy-Fix-username-issue-with-tarballs.patch32
-rw-r--r--meta-networking/recipes-connectivity/bluepy/bluepy_git.bb4
2 files changed, 35 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/bluepy/bluepy/0001-bluepy-Fix-username-issue-with-tarballs.patch b/meta-networking/recipes-connectivity/bluepy/bluepy/0001-bluepy-Fix-username-issue-with-tarballs.patch
new file mode 100644
index 0000000000..93b367a77b
--- /dev/null
+++ b/meta-networking/recipes-connectivity/bluepy/bluepy/0001-bluepy-Fix-username-issue-with-tarballs.patch
@@ -0,0 +1,32 @@
+From 318a0e7dfaa0f5f233a20c0b347948c8004cf6af Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 20 Oct 2021 14:02:09 -0700
+Subject: [PATCH] bluepy: Fix username issue with tarballs
+
+Fixes
+Cannot change ownership to uid 1000, gid 1000: Operation not permitted
+
+Upstream-Status: Submitted [https://github.com/IanHarvey/bluepy/pull/462]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ bluepy/Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+--- a/bluepy/Makefile
++++ b/bluepy/Makefile
+@@ -30,13 +30,13 @@ bluepy-helper: $(LOCAL_SRCS) $(IMPORT_SR
+ $(CC) -L. $(CFLAGS) $(CPPFLAGS) -o $@ $(LOCAL_SRCS) $(IMPORT_SRCS) $(LDLIBS)
+
+ $(IMPORT_SRCS): bluez-src.tgz
+- tar xzf $<
++ tar xzf $< --no-same-owner
+ touch $(IMPORT_SRCS)
+
+ .PHONY: bluez-tarfile
+
+ bluez-tarfile:
+- (cd ..; tar czf bluepy/bluez-src.tgz $(BLUEZ_PATH))
++ (cd ..; tar czf bluepy/bluez-src.tgz $(BLUEZ_PATH) --no-same-owner)
+
+ GET_SERVICES=get_services.py
+
diff --git a/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb b/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb
index bc1893eb08..887870fb78 100644
--- a/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb
+++ b/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb
@@ -7,7 +7,9 @@ DEPENDS = "glib-2.0"
SRCREV = "7ad565231a97c304c0eff45f2649cd005e69db09"
PV = "1.3.0+git${SRCPV}"
-SRC_URI = "git://github.com/IanHarvey/bluepy.git;protocol=https"
+SRC_URI = "git://github.com/IanHarvey/bluepy.git;protocol=https \
+ file://0001-bluepy-Fix-username-issue-with-tarballs.patch \
+ "
S = "${WORKDIR}/git"