aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Watt <JPEWhacker@gmail.com>2021-10-18 12:52:28 -0500
committerKhem Raj <raj.khem@gmail.com>2021-10-19 09:23:08 -0700
commit5a281d72d263458f776666b327ab92b6a18079fd (patch)
treeb6e7dd082be5a58b92c5c0940729d85bb3c7b0e7
parent646d2df67374fcc1d05260c403e46bee1d1d5443 (diff)
downloadmeta-openembedded-contrib-5a281d72d263458f776666b327ab92b6a18079fd.tar.gz
mutter: Move gsettings to a separate package
Move the mutter gsettings to their own package. Some other compositors (specifically, phoc) want to use the mutter provided gsettings to remain compatible. This allows those recipes to pick up the runtime settings without having to pull in all of mutter Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/mutter/mutter_3.34.6.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-gnome/recipes-gnome/mutter/mutter_3.34.6.bb b/meta-gnome/recipes-gnome/mutter/mutter_3.34.6.bb
index 72e776719e..b659d92952 100644
--- a/meta-gnome/recipes-gnome/mutter/mutter_3.34.6.bb
+++ b/meta-gnome/recipes-gnome/mutter/mutter_3.34.6.bb
@@ -73,7 +73,9 @@ do_install:append() {
done
}
-PACKAGES =+ "${PN}-tests"
+GSETTINGS_PACKAGE = "${PN}-gsettings"
+
+PACKAGES =+ "${PN}-tests ${PN}-gsettings"
FILES:${PN} += " \
${datadir}/gnome-control-center \
@@ -93,5 +95,5 @@ FILES:${PN}-dev += " \
${libdir}/${MUTTER_API_NAME}/lib*.so \
"
-RDEPENDS:${PN} += "zenity"
+RDEPENDS:${PN} += "zenity ${PN}-gsettings"