aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2021-02-16 22:16:30 +0000
committerKhem Raj <raj.khem@gmail.com>2021-02-19 10:02:43 -0800
commit31aceae5e73318d6003ba0141ea28596b6117a9b (patch)
tree280fd800ddc84f088644f7a3ac9c52a85e7a2bf1
parent81fbf11074f2b6d7e5635ee2ae6d93301f413627 (diff)
downloadmeta-openembedded-contrib-31aceae5e73318d6003ba0141ea28596b6117a9b.tar.gz
python3-intelhex: add recipe for the intelhex package
Signed-off-by: Ross Burton <ross.burton@arm.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-intelhex_2.3.0.bb10
2 files changed, 11 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index e31b0b8b40..635dee1942 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -170,6 +170,7 @@ RDEPENDS_packagegroup-meta-python3 = "\
python3-imageio \
python3-incremental \
python3-inflection \
+ python3-intelhex \
python3-intervals \
python3-ipaddress \
python3-ipy \
diff --git a/meta-python/recipes-devtools/python/python3-intelhex_2.3.0.bb b/meta-python/recipes-devtools/python/python3-intelhex_2.3.0.bb
new file mode 100644
index 0000000000..befcb34780
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-intelhex_2.3.0.bb
@@ -0,0 +1,10 @@
+SUMMARY = "Python library for Intel HEX files manipulations"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4eba844696655c3eae07aca8e3a94772"
+
+SRC_URI[sha256sum] = "892b7361a719f4945237da8ccf754e9513db32f5628852785aea108dcd250093"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"
+