aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-11-29 22:30:33 -0800
committerKhem Raj <raj.khem@gmail.com>2022-11-30 09:46:47 -0800
commit1704413322565e94c72b4851096372e445cd5487 (patch)
tree30293f68d83d9aeadf98f6f60d1ca33b1b19ab0c
parent0a81cfc3f9896cc3be3c0123f7f1538192c0406e (diff)
downloadmeta-openembedded-contrib-1704413322565e94c72b4851096372e445cd5487.tar.gz
rest: Re-add 0.8.1
Its needed by gfbgraph Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/rest/librest_0.8.1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/rest/librest_0.8.1.bb b/meta-gnome/recipes-gnome/rest/librest_0.8.1.bb
new file mode 100644
index 0000000000..23849783cc
--- /dev/null
+++ b/meta-gnome/recipes-gnome/rest/librest_0.8.1.bb
@@ -0,0 +1,35 @@
+SUMMARY = "library to access web services that claim to be "RESTful""
+HOMEPAGE = "https://wiki.gnome.org/Projects/Librest"
+LICENSE = "LGPL-2.1-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+DEPENDS = " \
+ gi-docgen \
+ gi-docgen-native \
+ glib-2.0 \
+ glib-2.0-native \
+ json-glib \
+ libsoup-2.4 \
+ libxml2-native \
+"
+
+inherit gnomebase gobject-introspection vala pkgconfig
+
+GNOMEBN = "rest"
+
+SRC_URI[archive.sha256sum] = "0513aad38e5d3cedd4ae3c551634e3be1b9baaa79775e53b2dba9456f15b01c9"
+
+S = "${WORKDIR}/${GNOMEBN}-${PV}"
+# * gnome environment requires libsoup build with in gnome PACKAGECONFIG
+# * libsoup-gnome support was removed upstream three years ago [1]
+# [1] https://gitlab.gnome.org/GNOME/librest/commit/8f904a8e2bb38a7bf72245cdf2f1ecad17e9a720
+EXTRA_OECONF = "--without-gnome"
+
+do_configure:prepend() {
+ # rest expects introspection.m4 at custom location (see aclocal.m4).
+ cp -f ${STAGING_DIR_TARGET}/${datadir}/aclocal/introspection.m4 ${S}/build
+}
+
+do_compile:prepend() {
+ export GIR_EXTRA_LIBS_PATH="${B}/rest/.libs"
+}