aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2021-07-16 09:27:37 -0400
committerKhem Raj <raj.khem@gmail.com>2021-07-20 09:27:56 -0700
commit04701ddaa77e77e64eea29f63e3025e83b95099a (patch)
tree5be2b63067a3549e4370804575f13f6f800dcc46
parentcd80092d94fa65f1a6501b00d9a5e567d9887181 (diff)
downloadmeta-openembedded-contrib-04701ddaa77e77e64eea29f63e3025e83b95099a.tar.gz
python3-cassandra-driver: add geomet to RDEPENDS, remove DISTUTILS options
python3-cassandra-driver is failing on do_install because the recipe is trying to pull sources while installing, but it can no longer do this because a recent change to python3-setuptools removing support for the deprecated ssl.match_hostname method. Since this only seems to occur when the DISTUTILS = "--no-libev" option to disable the libev extension is given, remove that from the recipe and let the extension be compiled into the package. Additionally, add python3-geomet (the dependency that cassandra-driver was trying to pull during do_install) to the RDEPENDS now that it exists as a recipe. Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-cassandra-driver_3.25.0.bb8
1 files changed, 1 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cassandra-driver_3.25.0.bb b/meta-python/recipes-devtools/python/python3-cassandra-driver_3.25.0.bb
index a1941bf3cb..ad446d6efa 100644
--- a/meta-python/recipes-devtools/python/python3-cassandra-driver_3.25.0.bb
+++ b/meta-python/recipes-devtools/python/python3-cassandra-driver_3.25.0.bb
@@ -10,17 +10,11 @@ SRCNAME = "cassandra-driver"
SRC_URI[sha256sum] = "8ad7d7c090eb1cac6110b3bfc1fd2d334ac62f415aac09350ebb8d241b7aa7ee"
-DISTUTILS_BUILD_ARGS += " \
- --no-libev \
-"
-DISTUTILS_INSTALL_ARGS += " \
- --no-libev \
-"
-
inherit pypi setuptools3
RDEPENDS_${PN} += "\
${PYTHON_PN}-cython \
+ ${PYTHON_PN}-geomet \
${PYTHON_PN}-json \
${PYTHON_PN}-misc \
${PYTHON_PN}-multiprocessing \