aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-09-30 13:35:11 -0700
committerKhem Raj <raj.khem@gmail.com>2020-10-01 10:35:21 -0700
commita599b850dc124444d06fbb5d48734c134325ac0c (patch)
treecd6f348b568138a199e3f553292266bf123e0c4e
parentd80b5a52fd9d91b27b7f1967a0f2d6ccb6e22991 (diff)
downloadmeta-openembedded-contrib-a599b850dc124444d06fbb5d48734c134325ac0c.tar.gz
numactl: Link with libatomic on rv64/rv32
Fixes riscv64-yoe-linux/10.2.0/ld: ./.libs/libnuma.so: undefined reference to `__atomic_fetch_and_1' Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/numactl/numactl_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/numactl/numactl_git.bb b/meta-oe/recipes-support/numactl/numactl_git.bb
index 75e4435db0..504fe03275 100644
--- a/meta-oe/recipes-support/numactl/numactl_git.bb
+++ b/meta-oe/recipes-support/numactl/numactl_git.bb
@@ -25,6 +25,9 @@ S = "${WORKDIR}/git"
# ARM does not currently support NUMA
COMPATIBLE_HOST = "^((?!arm).*)$"
+LDFLAGS_append_riscv64 = " -latomic"
+LDFLAGS_append_riscv32 = " -latomic"
+
do_install() {
oe_runmake DESTDIR=${D} prefix=${D}/usr install
#remove the empty man2 directory