aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Vickberg <wickbergster@gmail.com>2020-10-06 12:30:23 +0200
committerKhem Raj <raj.khem@gmail.com>2020-10-06 08:45:24 -0700
commit35459c1d2557446321e2377c2b7a1607067d4e1d (patch)
treef1039fb9a6026790ab63c93cb1c703b2014d25c5
parent02bb895d9d80b2a8c890944f9919894187e0db5b (diff)
downloadmeta-openembedded-contrib-35459c1d2557446321e2377c2b7a1607067d4e1d.tar.gz
wolfssl: upgrade 4.4.0 -> 4.5.0
Add patch from upstream which fixes building on big endian. Signed-off-by: Alexander Vickberg <wickbergster@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-connectivity/wolfssl/wolfssl/0001-Make-ByteReverseWords-available-for-big-and-little-e.patch32
-rw-r--r--meta-networking/recipes-connectivity/wolfssl/wolfssl_4.5.0.bb (renamed from meta-networking/recipes-connectivity/wolfssl/wolfssl_4.4.0.bb)6
2 files changed, 36 insertions, 2 deletions
diff --git a/meta-networking/recipes-connectivity/wolfssl/wolfssl/0001-Make-ByteReverseWords-available-for-big-and-little-e.patch b/meta-networking/recipes-connectivity/wolfssl/wolfssl/0001-Make-ByteReverseWords-available-for-big-and-little-e.patch
new file mode 100644
index 0000000000..4676769a43
--- /dev/null
+++ b/meta-networking/recipes-connectivity/wolfssl/wolfssl/0001-Make-ByteReverseWords-available-for-big-and-little-e.patch
@@ -0,0 +1,32 @@
+From b90acc91d0cd276befe7f08f87ba2dc5ee7122ff Mon Sep 17 00:00:00 2001
+From: Tesfa Mael <tesfa@wolfssl.com>
+Date: Wed, 26 Aug 2020 10:13:06 -0700
+Subject: [PATCH] Make ByteReverseWords available for big and little endian
+
+---
+ wolfcrypt/src/misc.c | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/wolfcrypt/src/misc.c b/wolfcrypt/src/misc.c
+index fe66ee0a1..23bfa1adc 100644
+--- a/wolfcrypt/src/misc.c
++++ b/wolfcrypt/src/misc.c
+@@ -120,7 +120,6 @@ WC_STATIC WC_INLINE word32 ByteReverseWord32(word32 value)
+ return rotlFixed(value, 16U);
+ #endif
+ }
+-#if defined(LITTLE_ENDIAN_ORDER)
+ /* This routine performs a byte swap of words array of a given count. */
+ WC_STATIC WC_INLINE void ByteReverseWords(word32* out, const word32* in,
+ word32 byteCount)
+@@ -131,7 +130,6 @@ WC_STATIC WC_INLINE void ByteReverseWords(word32* out, const word32* in,
+ out[i] = ByteReverseWord32(in[i]);
+
+ }
+-#endif /* LITTLE_ENDIAN_ORDER */
+
+ #if defined(WORD64_AVAILABLE) && !defined(WOLFSSL_NO_WORD64_OPS)
+
+--
+2.25.1
+
diff --git a/meta-networking/recipes-connectivity/wolfssl/wolfssl_4.4.0.bb b/meta-networking/recipes-connectivity/wolfssl/wolfssl_4.5.0.bb
index db7b0d486b..61cf1cc626 100644
--- a/meta-networking/recipes-connectivity/wolfssl/wolfssl_4.4.0.bb
+++ b/meta-networking/recipes-connectivity/wolfssl/wolfssl_4.5.0.bb
@@ -12,8 +12,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
PROVIDES += "cyassl"
RPROVIDES_${PN} = "cyassl"
-SRC_URI = "git://github.com/wolfSSL/wolfssl.git;protocol=https"
-SRCREV = "e116c89a58af750421d82ece13f80516d2bde02e"
+SRC_URI = "git://github.com/wolfSSL/wolfssl.git;protocol=https \
+ file://0001-Make-ByteReverseWords-available-for-big-and-little-e.patch \
+"
+SRCREV = "0fa5af9929ce2ee99e8789996a3048f41a99830e"
S = "${WORKDIR}/git"
inherit autotools