aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2020-09-30 17:31:39 +0000
committerKhem Raj <raj.khem@gmail.com>2020-10-07 08:42:21 -0700
commit1fa9a11c4242251bdb0370a816d16d527b1bc448 (patch)
treeb3d9c5a45ed20057935553a0692b5ac03b2f3481
parent35459c1d2557446321e2377c2b7a1607067d4e1d (diff)
downloadmeta-openembedded-contrib-1fa9a11c4242251bdb0370a816d16d527b1bc448.tar.gz
python3-pybind11: extend to native and nativesdk
Extend this recipe with native and nativesdk classes to be able to provide a package in SDK and run on the build system. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb b/meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb
index 9674ec0938..5d57590a12 100644
--- a/meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pybind11_2.5.0.bb
@@ -32,3 +32,5 @@ do_install() {
distutils3_do_install
cmake_do_install
}
+
+BBCLASSEXTEND = "native nativesdk"