aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <bgolaszewski@baylibre.com>2020-09-28 14:45:26 +0200
committerKhem Raj <raj.khem@gmail.com>2020-10-05 10:47:38 -0700
commit1ea3e2c4d25c58efd1dc33d8a0e945ae069f673a (patch)
treefd6fab92a900b6b9cdec5441a65566813c606a4f
parente82caab8059c00a8313dfb10d7327e9f25f58ba2 (diff)
downloadmeta-openembedded-contrib-1ea3e2c4d25c58efd1dc33d8a0e945ae069f673a.tar.gz
libgpiod: consolidate the recipe files
After dropping the support for v0.3.x, we no longer need the split into .bb and .inc files. Let's move the contents of libgpiod.inc into libgpiod_1.4.4.bb. While at it: do some refactoring: let's use ${BPN} in the URL, consolidate certain variables and add some explanatory comments. Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod.inc19
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod_1.4.4.bb24
2 files changed, 19 insertions, 24 deletions
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod.inc b/meta-oe/recipes-support/libgpiod/libgpiod.inc
deleted file mode 100644
index cae3145dd0..0000000000
--- a/meta-oe/recipes-support/libgpiod/libgpiod.inc
+++ /dev/null
@@ -1,19 +0,0 @@
-SUMMARY = "C library and tools for interacting with the linux GPIO character device"
-
-LICENSE = "LGPLv2.1+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
-
-SRC_URI = "https://www.kernel.org/pub/software/libs/libgpiod/${BP}.tar.xz"
-
-inherit autotools pkgconfig
-
-PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
-
-EXTRA_OECONF = "--enable-tools"
-
-PACKAGES =+ " ${PN}-tools"
-
-FILES_${PN}-tools = "${bindir}/*"
-
-PACKAGES =+ "libgpiodcxx"
-FILES_libgpiodcxx = "${libdir}/libgpiodcxx.so.*"
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_1.4.4.bb b/meta-oe/recipes-support/libgpiod/libgpiod_1.4.4.bb
index b5a64a554d..6433675ca4 100644
--- a/meta-oe/recipes-support/libgpiod/libgpiod_1.4.4.bb
+++ b/meta-oe/recipes-support/libgpiod/libgpiod_1.4.4.bb
@@ -1,17 +1,31 @@
-require libgpiod.inc
+SUMMARY = "C library and tools for interacting with the linux GPIO character device"
+AUTHOR = "Bartosz Golaszewski <bgolaszewski@baylibre.com>"
-DEPENDS += "autoconf-archive-native"
+LICENSE = "LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2caced0b25dfefd4c601d92bd15116de"
+SRC_URI = "https://www.kernel.org/pub/software/libs/${BPN}/${BP}.tar.xz"
SRC_URI[md5sum] = "064c2627397e6641c52de09a26951112"
SRC_URI[sha256sum] = "f1cda2789e6a13a92aefc012a76e5a7cc57a1b402d66f71df8719ee314b67699"
-# enable cxx bindings
-PACKAGECONFIG ?= "cxx"
+inherit autotools pkgconfig python3native
+PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,kmod udev"
PACKAGECONFIG[cxx] = "--enable-bindings-cxx,--disable-bindings-cxx"
PACKAGECONFIG[python3] = "--enable-bindings-python,--disable-bindings-python,python3"
-inherit python3native
+# Enable cxx bindings by default.
+PACKAGECONFIG ?= "cxx"
+
+# Always build tools - they don't have any additional
+# requirements over the library.
+EXTRA_OECONF = "--enable-tools"
+
+DEPENDS += "autoconf-archive-native"
+
+PACKAGES =+ "${PN}-tools libgpiodcxx"
+FILES_${PN}-tools = "${bindir}/*"
+FILES_libgpiodcxx = "${libdir}/libgpiodcxx.so.*"
PACKAGES =+ "${PN}-python"
FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"