aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-10-06 12:05:24 +0300
committerKhem Raj <raj.khem@gmail.com>2020-10-07 08:43:01 -0700
commit01c125358de95879b9c0d7838e7a3205f15f28da (patch)
treeac7effebae0114e9de8a1d88f894e3933967ed21
parent0c856b5fd9a765f229d24e78200fda163e90897c (diff)
downloadmeta-openembedded-contrib-01c125358de95879b9c0d7838e7a3205f15f28da.tar.gz
python3-prettytable: Upgrade 0.7.2 -> 1.0.0
Add a dependency on setuptools-scm and upgrade to release 1.0.0: - Dropped support for EOL Python 2.4-2.6 and 3.0-3.4. - Added support for Python 3.5-3.9. - Added del_column(field_name). - Added get_csv_string with delimiter option (comma or tab) and optional header. - Use wcwidth for better wide char support. - New paginate method can be used to produce strings suitable for piping to lp/lpr. - from_html now handles HTML tables with colspan, rather than choking on them. - Added min_width, min_table_width and max_table_width attribute/options for better control of table sizing. - Added "title" attribute/option for table titles. - When slice syntax is used to create a new sub-table out of an existing table, the rows are sorted before, not after, the slicing. The old behaviour (slice then sort) can be achieved by setting oldsortslice=True. - The from_csv table factory now accepts CSV format parameters as keyword arguments (e.g. delimiter, doublequote, escapechar, etc.) - Added 0x000f to the list of special characters with width 0, to fix problems with coloured strings produced by the Blessings library. - Fixed constructor argument float_format to work as intended. - Removed print_html() from README. - Added from_json and get_json_string to PrettyTable. - Fixed PLAIN_COLUMN to PLAIN_COLUMNS in README. - Added Markdown and Org mode styles. License-Update: Use wcwidth for better wide char support Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-prettytable_1.0.0.bb (renamed from meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb)8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb b/meta-python/recipes-devtools/python/python3-prettytable_1.0.0.bb
index 18f3390619..e5688a3866 100644
--- a/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb
+++ b/meta-python/recipes-devtools/python/python3-prettytable_1.0.0.bb
@@ -1,10 +1,10 @@
SUMMARY = "Python library for displaying tabular data in a ASCII table format"
HOMEPAGE = "http://code.google.com/p/prettytable"
LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://COPYING;md5=3e73500ffa52de5071cff65990055282"
+LIC_FILES_CHKSUM = "file://COPYING;md5=c9a6829fcd174d9535b46211917c7671"
-SRC_URI[md5sum] = "a6b80afeef286ce66733d54a0296b13b"
-SRC_URI[sha256sum] = "2d5460dc9db74a32bcc8f9f67de68b2c4f4d2f01fa3bd518764c69156d9cacd9"
+SRC_URI[md5sum] = "fb31d4c94fef42f2caf9784c44d8ea82"
+SRC_URI[sha256sum] = "98a3b74b1980e6a9392498e3a2a5406f6bd836f412843c2be23d9c88671747ac"
do_install_append() {
perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"`
@@ -23,6 +23,8 @@ SRC_URI += " \
file://run-ptest \
"
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
RDEPENDS_${PN} += " \
${PYTHON_PN}-math \
${PYTHON_PN}-html \