aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-02-04 23:20:02 -0800
committerKhem Raj <raj.khem@gmail.com>2019-02-05 16:43:12 -0800
commita07c969aebea4edb66babbc264777f626ed8eb7b (patch)
tree5451a0700e8137ca6241775777d7182c8faad344
parent8f6995ddc639a46d825aa0fc294ef589547ca6d3 (diff)
downloadmeta-openembedded-contrib-a07c969aebea4edb66babbc264777f626ed8eb7b.tar.gz
graphviz: Fix cross-build failures with clang
It is detecting cross compile badness for -lexpat since the check finds it on build host, so aide the build ssytem to find it in staging sysroot Disable internal ltdl, use libtool provided one Define defines to indicate that platform has ssize_t and long_double Disable java,r,c-sharp, as it is unused Arrange source URIs before checksums gtk-doc is not needed, morever it ends up in unknown configure options Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb18
1 files changed, 14 insertions, 4 deletions
diff --git a/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb b/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb
index 96f1efc60a..a9efffaca2 100644
--- a/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb
+++ b/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb
@@ -17,7 +17,7 @@ DEPENDS = " \
"
DEPENDS_append_class-target = " ${BPN}-native"
-inherit autotools-brokensep pkgconfig gtk-doc gettext
+inherit autotools-brokensep pkgconfig gettext
# The source tarball suggested at
# https://graphviz.gitlab.io/_pages/Download/Download_source.html has no
@@ -25,14 +25,24 @@ inherit autotools-brokensep pkgconfig gtk-doc gettext
# get checksum errors. Fedora people seem to expect same so they use a versioned
# source - see https://src.fedoraproject.org/cgit/rpms/graphviz.git/tree/graphviz.spec
-SRC_URI = "https://gitlab.com/graphviz/graphviz/-/archive/stable_release_${PV}/graphviz-stable_release_${PV}.tar.gz"
-SRC_URI[md5sum] = "2acf30ca8e6cc8b001b0334db65fd072"
-SRC_URI[sha256sum] = "e6c3f8dbfde1c4523055403927bef29f97f9fc12715c1042b5dcf648a2c1c62a"
+SRC_URI = "https://gitlab.com/graphviz/graphviz/-/archive/stable_release_${PV}/graphviz-stable_release_${PV}.tar.gz \
+"
# Use native mkdefs
SRC_URI_append_class-target = " file://0001-Use-native-mkdefs.patch"
+SRC_URI[md5sum] = "2acf30ca8e6cc8b001b0334db65fd072"
+SRC_URI[sha256sum] = "e6c3f8dbfde1c4523055403927bef29f97f9fc12715c1042b5dcf648a2c1c62a"
S = "${WORKDIR}/${BPN}-stable_release_${PV}"
+EXTRA_OECONF_class-target = "\
+ --with-expatincludedir=${STAGING_INCDIR} \
+ --with-expatlibdir=${STAGING_LIBDIR} \
+ --without-included-ltdl \
+ --disable-java \
+ --disable-r \
+ --disable-sharp \
+ "
+CFLAGS_append_class-target = " -D_typ_ssize_t=1 -D_long_double=1"
do_configure_prepend() {
cd ${S}
# create version.m4 and ignore libtoolize errors