aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-01-04 09:25:54 -0800
committerKhem Raj <raj.khem@gmail.com>2024-01-18 07:30:48 -0800
commit1647e20b2edda3320b8ec601d78572251a288eeb (patch)
tree34214aa6c9b7a05b753d7b0bf49072751c31f5f4
parentc076a263517e4dc52b115acc4ead8e3ddfcdded1 (diff)
downloadmeta-openembedded-contrib-1647e20b2edda3320b8ec601d78572251a288eeb.tar.gz
evolution-data-server: Use inherit_defer for native class
Since gnome classes are using it in core, they are now appearing after native resulting in QA errors ERROR: /mnt/b/yoe/master/sources/meta-openembedded/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server-native.bb: QA Issue: evolution-data-server-native: native/nativesdk class is not inherited last, this can result in unexpected behaviour. Classes inherited after native/nativesdk: pkgconfig.bbclass siteconfig.bbclass siteinfo.bbclass autotools.bbclass [native-last] secondly, use 'cmake' for GNOMEBASEBUILDCLASS default is set to meson (legacy is autotools) since most of gnome recipes are using meson these days. This recipe however uses neither autotools nor meson to build, it uses cmake, to this effect it inherits cmake bbclass and things worked so far, however with inherit_defer things changed because meta/classes-recipe/gnomebase.bbclass has switched to using inherit_defer, this unearths this issue where its not overriding exported functions as desired. Therefore this fixes that issue Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server-native.bb4
-rw-r--r--meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb2
-rw-r--r--meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.inc2
3 files changed, 5 insertions, 3 deletions
diff --git a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server-native.bb b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server-native.bb
index 681a61c33a..28d4c2152b 100644
--- a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server-native.bb
+++ b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server-native.bb
@@ -1,10 +1,12 @@
require ${BPN}.inc
-inherit native
+inherit_defer native
DEPENDS = "glib-2.0-native"
# build native helpers
+do_configure[noexec] = "1"
+
do_compile() {
cd ${S}/src/camel
sed -i 's:#include "evolution-data-server-config.h"::g' camel-gen-tables.c
diff --git a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb
index 11a52b455e..0c3cc53030 100644
--- a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb
+++ b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb
@@ -6,7 +6,7 @@ DEPENDS = " \
dbus db virtual/libiconv zlib libsoup-3.0 libical nss libsecret \
"
-inherit pkgconfig gsettings gobject-introspection features_check cmake gtk-doc gettext perlnative vala
+inherit pkgconfig gsettings gobject-introspection features_check gtk-doc gettext perlnative vala
ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
REQUIRED_DISTRO_FEATURES = "opengl"
diff --git a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.inc b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.inc
index 2f3bf61982..33190c461c 100644
--- a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.inc
+++ b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.inc
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6a6e689d19255cf0557f3fe7d7068212 \
file://src/camel/camel.h;endline=24;md5=342fc5e9357254bc30c24e43ae47d9a1 \
file://src/libedataserver/e-data-server-util.h;endline=20;md5=8f21a9c80ea82a4fb80b5f959f672543"
-GNOMEBASEBUILDCLASS = "autotools"
+GNOMEBASEBUILDCLASS = "cmake"
inherit gnomebase upstream-version-is-even
SRC_URI[archive.sha256sum] = "91f4ffc38a1b8d2fe8939834449ac541c0bff4a39b444edc2a9529344a28e98a"