summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lippautz <michael.lippautz@gmail.com>2011-07-05 20:31:55 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-07-09 11:35:36 +0200
commit32626159e648e7b0b7ab9956c2fc8b91bb1e645c (patch)
treeab5cfc020c95bc8c0bf67923c0d0c9d78161c150
parentb77b973a58d1edd6d077013f6e71268b2e9294f2 (diff)
downloadmeta-openembedded-contrib-32626159e648e7b0b7ab9956c2fc8b91bb1e645c.tar.gz
python-pyudev: Add version 0.11 (initial recipe)
Signed-off-by: Michael Lippautz <michael.lippautz@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/python/python-pyudev_0.11.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-pyudev_0.11.bb b/meta-oe/recipes-devtools/python/python-pyudev_0.11.bb
new file mode 100644
index 0000000000..03a948a61f
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-pyudev_0.11.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "A libudev binding"
+HOMEPAGE = "http://pypi.python.org/pypi/pyudev"
+SECTION = "devel/python"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
+PR = "r0"
+
+SRCNAME = "pyudev"
+SRC_URI = "http://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+SRC_URI[md5sum] = "dca4e69da387f9a6683ee4b5c27ca66a"
+SRC_URI[sha256sum] = "0acfa500219f4bcf711f35c1b2041d035b4bf5f302eca5038572ee788d9e584a"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} = "\
+ python-ctypes \
+ python-subprocess \
+ python-misc \
+ libudev \
+"