aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiweiSong <liwei.song@windriver.com>2021-09-29 12:04:10 +0800
committerKhem Raj <raj.khem@gmail.com>2021-09-29 07:23:22 -0700
commitae1705aad57a80a1122ebef117ea689d7307171f (patch)
treebb9359c83529c7a6acf9fd929bc4449e32f6b116
parent0c38f98f120b0c107487ba2ae9701bf26d4a1645 (diff)
downloadmeta-openembedded-contrib-ae1705aad57a80a1122ebef117ea689d7307171f.tar.gz
chipsec: platform security assessment framework
Add chipsec, tools to dump and analyzing hardware, system firmware components, like PCH register, ioport or iomem configuration space. Signed-off-by: Liwei Song <liwei.song@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-bsp/chipsec/chipsec_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-bsp/chipsec/chipsec_git.bb b/meta-oe/recipes-bsp/chipsec/chipsec_git.bb
new file mode 100644
index 0000000000..3339dc1421
--- /dev/null
+++ b/meta-oe/recipes-bsp/chipsec/chipsec_git.bb
@@ -0,0 +1,35 @@
+SUMMARY = "CHIPSEC: Platform Security Assessment Framework"
+
+DESCRIPTION = "CHIPSEC is a framework for analyzing the security \
+ of PC platforms including hardware, system firmware \
+ (BIOS/UEFI), and platform components."
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=bc2d1f9b427be5fb63f6af9da56f7c5d"
+
+SRC_URI = "git://github.com/chipsec/chipsec.git;branch=master \
+ "
+
+SRCREV = "b2a61684826dc8b9f622a844a40efea579cd7e7d"
+
+COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
+
+S = "${WORKDIR}/git"
+EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'"
+
+DEPENDS = "virtual/kernel nasm-native python3-setuptools-native"
+RDEPENDS:${PN} += "python3 python3-modules"
+
+inherit module distutils3
+
+do_compile:append() {
+ cd ${S}/drivers/linux
+ oe_runmake KSRC=${STAGING_KERNEL_BUILDDIR}
+}
+
+do_install:append() {
+ install -m 0644 ${S}/drivers/linux/chipsec.ko ${D}${PYTHON_SITEPACKAGES_DIR}/chipsec/helper/linux
+}
+
+FILES:${PN} += "${exec_prefix} \
+"