aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-08-04 10:18:46 -0700
committerKhem Raj <raj.khem@gmail.com>2021-08-06 20:38:40 -0700
commitfb95946eb51f6500b703ffb51822fa551b242db9 (patch)
tree707c9f8e26358ea337ad6630358e2c4b16b96225
parent2871edc40c8649e67fddc103101a8b64c5227b26 (diff)
downloadmeta-openembedded-contrib-fb95946eb51f6500b703ffb51822fa551b242db9.tar.gz
emacs,libgpiod,cockpit: Fix override syntax in using FILES_${PN}
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/emacs/emacs_27.2.bb2
-rw-r--r--meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb2
-rw-r--r--meta-webserver/recipes-webadmin/cockpit/cockpit_220.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/emacs/emacs_27.2.bb b/meta-oe/recipes-support/emacs/emacs_27.2.bb
index 485d78ce4b..a91c465c1f 100644
--- a/meta-oe/recipes-support/emacs/emacs_27.2.bb
+++ b/meta-oe/recipes-support/emacs/emacs_27.2.bb
@@ -253,7 +253,7 @@ FILES:${PN}-base = " \
"
# Restore FILES for the full package to catch everything left
-FILES:${PN}-full = "${FILES_${PN}}"
+FILES:${PN}-full = "${FILES:${PN}}"
FILES:${PN}-full:append = " ${datadir}/icons"
diff --git a/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb b/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb
index 38bd23711e..ac4ba85d77 100644
--- a/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb
+++ b/meta-oe/recipes-support/libgpiod/libgpiod_1.6.3.bb
@@ -63,7 +63,7 @@ do_install_ptest() {
# we're not selecting libgpiod-tools.
install -m 0755 ${S}/tools/gpio-tools-test ${D}${PTEST_PATH}/tests/
install -m 0755 ${S}/tools/gpio-tools-test.bats ${D}${PTEST_PATH}/tests/
- for tool in ${FILES_${PN}-tools}; do
+ for tool in ${FILES:${PN}-tools}; do
install ${B}/tools/.libs/$(basename $tool) ${D}${PTEST_PATH}/tests/
done
diff --git a/meta-webserver/recipes-webadmin/cockpit/cockpit_220.bb b/meta-webserver/recipes-webadmin/cockpit/cockpit_220.bb
index c49ba04564..7c3c17cd78 100644
--- a/meta-webserver/recipes-webadmin/cockpit/cockpit_220.bb
+++ b/meta-webserver/recipes-webadmin/cockpit/cockpit_220.bb
@@ -181,7 +181,7 @@ do_install:append() {
rm -rf ${D}${libdir}/firewalld
if ! ${@bb.utils.contains('PACKAGECONFIG', 'storaged', 'true', 'false', d)}; then
- for filename in ${FILES_${PN}-storaged}
+ for filename in ${FILES:${PN}-storaged}
do
rm -rf ${D}$filename
done