aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Battersby <tonyb@cybernetics.com>2021-08-09 10:32:43 -0400
committerKhem Raj <raj.khem@gmail.com>2021-08-09 10:20:30 -0700
commitc40e01b0fce73bc289d9499b204350359afc7884 (patch)
tree1dc5d6e25c4e09af6e123561f42b10a203e0f8f2
parent3cf2475ea059184820525bb949c11c3da0e64af8 (diff)
downloadmeta-openembedded-contrib-c40e01b0fce73bc289d9499b204350359afc7884.tar.gz
curlpp: fix QA Issue after LDFLAGS change
Adding -f*-prefix-map to LDFLAGS caused the following issue: QA Issue: curlpp.pc failed sanity test (tmpdir) Fix by filtering out -f*-prefix-map from *.pc files. [YOCTO #14481] Signed-off-by: Tony Battersby <tonyb@cybernetics.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
index 6ce52d7179..263de81c70 100644
--- a/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
+++ b/meta-networking/recipes-support/curlpp/curlpp_0.8.1.bb
@@ -16,3 +16,10 @@ S = "${WORKDIR}/git"
inherit cmake pkgconfig binconfig
BBCLASSEXTEND = "native nativesdk"
+
+do_install:append() {
+ sed -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \
+ -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
+ -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
+ -i ${D}${libdir}/pkgconfig/*.pc
+}